Page MenuHome

When loading any add-ons or when using any edit mode hotkeys blender reports a crash.
Closed, ResolvedPublic

Description

System Information
Windows 10 GTX 970 (driver v: 398.82)

Blender Version
Broken: blender2.8 - 2018-08-06 02:54 - f7b1fec463e
Worked: Unable to pinpoint exact version as buildbot downloads since 6/4/18 have been deleted

Short description of error
When ever an add-on attempts to load, a traceback error popup comes up. There is a special case of cycles where it still shows up as a render engine, but whenever render mode is entered, blender instantly hard crashes as I'm guessing the actual engine failed to load.

When pressing some hotkeys that changes the mesh ( for example extrue) shows a traceback error popup. Note that this does not happen when trying to use something from the T panel. (same thing happens in node editor when creating new node from Shift+A but not when duplicating)

Exact steps for others to reproduce the error
Addon failing to load:

  1. open settings
  2. enable any 2.8 add-on

Edit mode hotkeys:

  1. Enter edit mode
  2. press E

Blend file:

Full output log for trying to render something in cycles: https://pastebin.com/ji1PC2Ne

Short clip demonstrating problems:

Details

Type
Bug

Related Objects

Event Timeline

Campbell Barton (campbellbarton) triaged this task as Needs Information from User priority.EditedAug 7 2018, 2:34 AM

Can't redo this: Does it happen if you run: import enum in the Python console? (instead of enabling the addon)

Well I'm sorry to say but I'm unable to do this as i'm completely locked out of the python console or text editor.
This error instantly happens when I open the scripting workspace and after that when I click or do a key down or bizarrely when I move the window.

Traceback (most recent call last):
  File "C:\Blender\2.8\2.80\scripts\modules\bpy\utils\__init__.py", line 171, in register_module_call
    register()
  File "C:\Blender\2.8\2.80\scripts\startup\bl_operators\__init__.py", line 68, in register
    register_class(cls)
ValueError: register_class(...): already registered as a subclass

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "C:\Blender\2.8\2.80\scripts\startup\bl_operators\console.py", line 124, in execute
    module = _lang_module_get(sc)
  File "C:\Blender\2.8\2.80\scripts\startup\bl_operators\console.py", line 32, in _lang_module_get
    level=0)
  File "C:\Blender\2.8\2.80\scripts\modules\console_python.py", line 21, in <module>
    import bpy
  File "C:\Blender\2.8\2.80\scripts\modules\bpy\__init__.py", line 81, in <module>
    main()
  File "C:\Blender\2.8\2.80\scripts\modules\bpy\__init__.py", line 78, in main
    utils.load_scripts()
  File "C:\Blender\2.8\2.80\scripts\modules\bpy\utils\__init__.py", line 246, in load_scripts
    test_register(mod)
  File "C:\Blender\2.8\2.80\scripts\modules\bpy\utils\__init__.py", line 213, in test_register
    register_module_call(mod)
  File "C:\Blender\2.8\2.80\scripts\modules\bpy\utils\__init__.py", line 173, in register_module_call
    import traceback
  File "C:\Blender\2.8\2.80\python\lib\traceback.py", line 5, in <module>
    import linecache
  File "C:\Blender\2.8\2.80\python\lib\linecache.py", line 8, in <module>
    import functools
  File "C:\Blender\2.8\2.80\python\lib\functools.py", line 22, in <module>
    from types import MappingProxyType
ImportError: cannot import name 'MappingProxyType'

location: <unknown location>:-1

location: <unknown location>:-1

Is there any other way I can do this? I have blender ready in visual studio, although I have to warn that I'm not that experienced with C++ or Python.

Seems like there is something broken about your Python installation then.

Moving this to unconfirmed since many people would report this if it were common.

Alright so as an update to this... I found out what was the problem.

I somehow managed to put an addon source (as individual files) in the addons folder in user preferences. Once I deleted it everything was working fine.
This is an error on my behalf so it's not a blender problem. (unless you want to make it foolproof)

Lapis Sea (LapisSea) closed this task as Resolved.Aug 10 2018, 2:55 PM