Page MenuHome

Blender 2.8 selection inconsistent between mouse and pen.
Closed, ResolvedPublic

Description

System Information
AMD A4
Radeon hd 8370D

Blender Version
0f449541d2e

Short description of error
Selection of overlapped objects will fail if the cursor has been moved.

Exact steps for others to reproduce the error
In a a row of objects, position the view is such a way that them got occluded, then try to select the object underneath.
It should select the next occluded object at each click and cycling back, and that happens unless you don't click at the exact same pixel all time.

But there's a problem :
We all know that's impossible to not move the pen while clicking with it so, it will require cirurgical precision to select with the graphic pen, and it's not the point if a graphic pen.

Event Timeline

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but that is not a bug, that’s a limitation related to a specific input device… Also, I’m assuming you are aware of the ALT-RCLICK that pops up a menu to select any object below the click?

I an aware of the alt click and also aware that this is a downgrade compared to 2.7 and shoud be fixed since before it worked fine.

Alt+click has a negative side: when you have lots of objects and dont have time to name everything the alt+click menu just become a messy list that is even harder to use.

As you might see on this post on devtalk, it's actually an undesirable behavior,
We need selection to behave consistently either by moving the mouse between clicks or not.
https://devtalk.blender.org/t/2-8-wireframes-selection-difficult/4927

Philipp Oeser (lichtwerk) triaged this task as Normal priority.

Not sure if this would be considered a bug.

Can confirm this feels more sensitive than 2.79 though.
seems to be defined in mixed_bones_object_selectbuffer_extended()

if (len_manhattan_v2v2_int(mval, last_mval) < 3) {
	do_nearest = false;
}

If I increase the value from 3 to lets say 20 or so, I can comfortably select with my pen.

@Campbell Barton (campbellbarton): should this be increased a bit? (made a preference?)

@Philipp Oeser (lichtwerk) the purpose of this check is to cycle though items under the cursor when you're not moving it.

This should be a very small value - otherwise the users might move the cursor slightly to select a different item - instead of selecting what is now under the cursor - it will select the *next* item from all items near the cursor.


Would rather avoid a preference - although we could have one which is the distance allowed before the cursor is considered to have moved. (different from drag distance).

Committed rB57395061042fe336dae7ee33e3ae11e53d068194 adding WM_EVENT_CURSOR_MOTION_THRESHOLD which is now scaled by the DPI, if it's still needed the preference can be added there too.

@Philipp Oeser (lichtwerk) the purpose of this check is to cycle though items under the cursor when you're not moving it.

This should be a very small value - otherwise the users might move the cursor slightly to select a different item - instead of selecting what is now under the cursor - it will select the *next* item from all items near the cursor.

Would rather avoid a preference - although we could have one which is the distance allowed before the cursor is considered to have moved. (different from drag distance).
Committed rB57395061042fe336dae7ee33e3ae11e53d068194 adding WM_EVENT_CURSOR_MOTION_THRESHOLD which is now scaled by the DPI, if it's still needed the preference can be added there too.

@Campbell Barton (campbellbarton) notice that tablet pens can't hold the cursor still because electromagnetic noise plus the fact that holding a pen still in midair always hard, the muscles always twitch a bit, this effect is so evident that you can easily tell if someone is using a mouse or a pen in a recorded video. Because of that, I would set this threshold to at least 5 or 6 pixels.