Page MenuHome

Setting Segments or Normal Strength in the new Bevel Modifier Crashes Blender
Closed, ResolvedPublic

Description

System Information
Windows 10 Pro 64Bit
NVidia P4000
All Drivers up to date

Blender Version
Broken: Blender 2.8 5b6dde22935
Worked: NA
Blender crashes when adjusting normal strength or segments once Normal Mode is set to "Face Area". This crash occurs whether the number is directly entered with the keyboard or if the slider is adjusted.

Exact steps for others to reproduce the error

  1. Open Blender, Select Default Cube
  2. Add Bevel Modifier
  3. Set Segments to "3"
  4. Set Normal Mode to "Face Area"
  5. Set Normal Strength to "1"
  6. Watch Blender Crash

Note: Steps 3 and 5 can be reversed. In this case, with Normal Strength set to 1, adjust the segments count to a number other than one.

To reproduce in the blend file, go to the bevel modifier for the cube and adjust the Normal Strength up to 1.

Details

Type
Bug

Event Timeline

I wanted to add that any other value for Normal Strength works without issue. For instance I can type 0.99 into the field and click the the right spinner value arrow and there is an instant crash.

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

@Rohan Rathi (RohanRathi) will let you decide whether those are same reports or not (with T56286).

Dan Pool (dpdp) added a comment.EditedAug 10 2018, 5:33 PM

It looks like these are the same issue. T56286 = T56287. The other wasn't posted yet when I started my bug report. I didn't post a blend file since it was a single modifier added to the default cube, but if you guys need to save that little bit of time (I know these things add up) I'm editing the post now to get one attached.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Confirmed, Medium.

Thanks, confirmed.

Howard Trickey (howardt) closed this task as Resolved.Aug 31 2018, 12:08 PM