Page MenuHome

Knife Tool Fractures Mesh
Closed, ResolvedPublic

Description

System Information
Win7 Professional, 12GB ram, and Processor Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz, 2601 Mhz, 4 Core(s), 8 Logical Processor(s)

Blender Version
Broken: 2.79b

Short description of error
When knife tool is used to draw closed shape it fractures the mesh into multiple large parts

Exact steps for others to reproduce the error


Use the knife tool and cut any closed shape in the plane.

Then this happens

Details

Type
Bug

Event Timeline

this is a bug if you cut out a line using knife lines appear all over the mesh.

There are two things going on here and I am not sure which you are trying to report.

First, if you draw a closed shape inside a face with knife, then it is expected behavior that that closed shape will be made but that additional edges will connect from vertices of that closed shape to vertices of the face that you drew it in. The reason this is required is because Blender's format for storing meshes does not (at the moment) allow for 'holes' in faces. The only way to get such a hole is to connect it up with at least two edges to the enclosing face.

Is this the problem you were trying to report, Nick? If so, we will close this as 'working as intended'.

But another issue is that your second file (both are named Bug.blend - please don't do that in future) shows a cut that has a strange inner face with some repeated vertices (it looks like a pentagon, but examining the data blocks we can see that it has 8 vertices, some doubled). I don't know how that happened, since we don't know what user interface things you did to draw the face. Maybe you clicked twice in the same place? Because of the repeated vertices, this is not a good mesh and will not shade well. Is this what you were trying to report, Nick? To get something really repeatable, it might be best to generate a separate object that is the shape you want to cut, and then use knife project -- then it will be repeatable.

I tried playing around with cutting closed shapes in current master (the 2.79 series, but developed some beyond 2.79b) and in the 2.8 branch. In 2.7, I could sometimes get results that seemed a little strange to me -- more than two edges were used to connect to the outer face. But I couldn't get that to happen in 2.8. So I guess we've diverged some on what the edgenet connect function does (that's the internal routine that is connecting up the hole -- the island, we call it -- to the outer face).

Campbell, if this is a master-only problem, do you think it is worth finding and fixing? I get the feeling we are unlikely to maintain the 2.79 series much longer unless there are very serious/crashing kinds of bugs, which this is not.

Howard Trickey (howardt) closed this task as Resolved.Aug 15 2018, 3:03 PM

After talking with Campbell, have decided to close this one for now. If we can reproduce that second issue in 2.8, then can reopen with a repeatable test case (using script or knife project).