Driven values not supported in node groups
Closed, ResolvedPublic

Description

System Information
Win 10, Intel Iris Plus Graphics 640 (integrated)

Blender Version
Broken: 2.8 daily builds as of 13/08/2018

Short description of error
Creating a node group of containing driven value crashes blender.

Exact steps for others to reproduce the error

  • Open Default Scene
  • Change 3D view to Shader Editor
  • Enable "Use Nodes"
  • Add "Value" node
  • insert "#frame" into value's input
  • Select "Value" node
  • Select Node> Make Group
Bastien Montagne (mont29) triaged this task as Incomplete priority.Aug 14 2018, 8:59 AM

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

I have reviewed both links you have mentioned, and I believe I have provided sufficient information as per the template and guidelines. All required information is present, the steps are clear and concise, and I cannot produce a file in the final state, due to the crash occurring.

What information is missing from the above report?

@Chris Cook (CCook) Create a file until the last step, this file will save time.

@Bastien Montagne (mont29) Update guidelines, explain why you need (always) the file, even if it's a default scene, etc.


Here is the file just before doing the last step

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Confirmed.

@Yevgeny Makarov (jenkm) am beyond being tired to repeat the same over and over and over, this has already been explained gazillions of times.

@Chris Cook (CCook) thanks, confirmed.