Page MenuHome

UI Fonts broken
Closed, ResolvedPublic

Description

System Information
All operation Systems (Windows 10 64 bit, OSX 10.11.6, Ubuntu 17.10 Gnome)

Blender Version
Broken: 2.79.6
Worked: 2.79 (and 2.79.4)

The UI fonts are ugly, kerning seems broken (?). We made some gifs which show the problem. It might seem marginal but readability really goes down (see node editor gif).

Details

Type
Bug

Event Timeline

You can disable "Text Hinting" in User Preferences > System.

It seems to be related to this D3581.

Thank you! It was really no pleasure to work with blender the last couple of days ;)

Shouldn't it be disabled per default to keep the "normal" look then?

Bastien Montagne (mont29) triaged this task as Normal priority.Aug 14 2018, 3:51 PM

Change caused by rB18888b7b0c3556d. So would say that is expected behavior, will let @Campbell Barton (campbellbarton) make final decision here though.

there's some discussion about this in D3581 as well.

Hinting can sometimes add space between characters, but that does seem rather a lot.

Also, the characters on the unhinted example are running into each other slightly which is exaggerating the difference.

A comparison of Droid Sans in Freetype's font viewer (ftview) on Linux, as close to the same point size as I could get it:


(v35 interpreter)
The char spacing between the hinted and unhinted is very similar, but the former being marginally narrower.

Default font and zoom size, hinted looks terrible:

Arial font (standard Windows 7), not much difference, hinted more crisp:

Brecht Van Lommel (brecht) closed this task as Resolved.Thu, Apr 4, 4:49 AM

The change that caused this problem was reverted, so it should be solved.