Page MenuHome

Grease Pencil is showed intermittently on Mac
Closed, ResolvedPublic

Description

System Information
Retina 5K, 27-inch, Late 2015, 3,3 GHz Intel Core i5, 8 GB 1867 MHz DDR3, AMD Radeon R9 M395 2048 MB

Blender Version
last Blender 2.8 Alpha 2

I'd like to test some Grease Pencil but Suzanne and other "draws" seem to appear and disappear. I test on a Linux Partition and it seems it works fine, it looks fine, but my screen-tablet doesn't works. It's not a Wacom, a XP-Pen.

Thanks

Details

Type
Bug

Related Objects

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Aug 19 2018, 4:39 PM

@Arto Kitula (akitula), maybe you can confirm? Thanks

Hello!
Is this what you're talking about?
https://youtu.be/T5PkOPs8lrg
(Watch until the end for my machines specs).
This seems only to happen with the AMD GPU (Radeon Pro 455 in my case).
As a test, I've forced MacOs to use the Intel HD Graphics 530 and it works as expected (although everything seems really slow).

Hello! Yeah! it’s exactly wha I tried to say. Slow? How slow is it expected? I’m thinking to work in Linux only for Blender.

Hey!
I did a second comparison ADM/Intel.
https://youtu.be/fAMas7tH8GA
AMD: Graphic glitches galore, but fast interaction.
Intel: No glitches, but object manipulation feels really sluggish.

Er, I'm not really used to these forums so sorry in advance for asking.
Is anyone taking care of this MacOs gfx problem? Or need more information?
Happy to help if I can...

Ok I found a solution.
It seems like the Viewport Quality Settings (in User Preferences/System) when set to anything else than 0, screws up the 3D Viewport.
In short, for anyone having the above problem on MacOs, put that setting on 0.
Voilà!

I’ll try it. Thanks

The above suggestion works, except in my case anything >= 0.250 caused strokes to disappear. Anything under that was fine. Using a Macbook Pro with latest update.

Brecht Van Lommel (brecht) closed this task as Resolved.Nov 2 2018, 7:38 PM
Brecht Van Lommel (brecht) claimed this task.

I believe this was fixed last week along with various other macOS bugs.