Page MenuHome

freestyle stroke material test fails.
Closed, ResolvedPublic

Description

System Information
Win7 X64

Blender Version
Broken: Latest master
Worked: this has been broken for months and months but never bothered to report it.

Short description of error

Resultreferencedifference

Exact steps for others to reproduce the error
render render\ctests\render_layer\freestyle_stroke_material.blend

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Normal priority.

Thing is, we have no idea whether that is supposed to be expected changes (and test should be updated), or if that’s actually valid bug… reporting that kind of issue months later is not reallyt helpfull either. :/

I confirm that, under linux, render is compliant to reference with 2.79b or master. So, it is a bug relative to OS.

Thing is, i generally only run the unit tests when i either have to do a blender.org release or when i do library upgrades. having this many tests broken before I even start isn't great for me either, and makes quite a good case for running the unit-tests on the build-bot on a nightly basis. I'm happy to investigate most of the unit test issues reported (since most of them do appear to be platform specific) but i did think it was worth while to have a tracker ticket so we're aware that there's an issue and module owners of the problem area's can chime in and either fix the issue or give me a hint on where to look.

Brecht Van Lommel (brecht) closed this task as Resolved.Apr 4 2019, 4:45 AM