mesh + armature exported in FBX format (7.4 binary or 6.1 ASCII) and imported in NUKE 11 does not work well.
Closed, InvalidPublic

Description

System Information

Operating system and graphics card = Windows 10 and NVIDIA GEFORCE GTX 1060 3 GB

Blender Version = 2.79b

Short description of error

If you create an armature with the rigging system that you want and and then you bind it to a character's mesh and then you export the mesh AND the armature to FBX 6.1 ASCII and then you import them in NUKE 11,it crashes a lot of time. Instead,if you export them to FBX 7.4 Binary,the mesh and the armature are not imported at all.

I have also created this post :

https://blender.stackexchange.com/questions/117123/how-to-export-correctly-mesh-and-armature-of-a-character-from-blender-to-nuke

*Exact steps for others to reproduce the error**

Based on a (as simple as possible) attached .blend file with minimum amount of steps

below you can see the FBX settings that I have used...

Details

Type
Bug
mario (ziomario) updated the task description. (Show Details)
mario (ziomario) updated the task description. (Show Details)
mario (ziomario) updated the task description. (Show Details)
mario (ziomario) renamed this task from mesh + armature exported in FBX format (7.4 binary or 6.1 ASCII) and in Alembic and imported in NJKE 11 does not work well. to mesh + armature exported in FBX format (7.4 binary or 6.1 ASCII) and imported in NJKE 11 does not work well..Wed, Aug 29, 12:29 PM
mario (ziomario) updated the task description. (Show Details)
mario (ziomario) renamed this task from mesh + armature exported in FBX format (7.4 binary or 6.1 ASCII) and imported in NJKE 11 does not work well. to mesh + armature exported in FBX format (7.4 binary or 6.1 ASCII) and imported in NUKE 11 does not work well..
Bastien Montagne (mont29) closed this task as Archived.Sun, Sep 2, 4:32 PM
Bastien Montagne (mont29) claimed this task.

Thanks for the report, but this sounds more like user support than bug to me - we don’t even know whether Nuke supports rigging at all, even less if it can import it correctly from FBX…

We do not handle user support on this tracker, only bug reports. User forums like blenderartists.org or blender.stackexchange.com should be used for that matter.

mario (ziomario) added a comment.EditedSun, Sep 2, 5:11 PM

ok for the armature,but not good for the mesh. Nuke should import correctly the FBX file format.both in 6.1 ASCII and in 7.4 binary format. If it does not do it correctly,it's a bug of blender. So,I suggest to re open this bug. And anyway,the question deserves to be deepened,not closed on two feets.

mario (ziomario) reopened this task as Open.Sun, Sep 2, 5:13 PM

You’ll have to give proof that issue is from Blender side, not from Nuke side first… afaik meshes are pretty reliable in our FBX io addon. Not our job to investigate that kind of issue, especially not with a closed-source software we don’t have access to.

mario (ziomario) added a comment.EditedMon, Sep 3, 9:49 AM

I think that it not necessary to look into the code as first thing to check. Maybe I used wrong configuration on the settings of the FBX panel,or it's necessary to use a "special" combination of settings,that I don't know. The best solution I think could be to make some attempts by the cross users,users who uses/know blender and nuke. I think that it worth trying before to close this post. If It was not strictly a bug,it was very close to be a bug,because each combination of setting should produce a different kind of effect,but since it could work only in some circumstances,it could be a bug.

mario (ziomario) reopened this task as Open.Mon, Sep 3, 9:50 AM

That’s the last time I say it: THIS BUGTRACKER IS NOT A USER SUPPORT SERVICE!

I have other things to do than closing three times the same task because you cannot understand that this is not a valid bug report! Last warning, next time I’ll disable your account.

ok. you are the coder.