Page MenuHome

Blender crash when resizing main window
Closed, ArchivedPublic

Description

System Information
Windows 10, Intel Iris 540

Blender Version
Broken: 2.8 Alpha 2 (2018-09-10 build)

Short description of error
Crash - blender exits.

Exact steps for others to reproduce the error
Start blender.
Resize main window from bottom corner.
Blender closes.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Most certainly a driver issue, Please:

  • Give us your exact Blender, OS and GPU (including drivers) versions, as requested in the template!
  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker or open source ones in linux distributions).
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak OGL settings in UserPreferences, System tab.
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
  • Attach as text file here the report generated by Help -> System Info (do not paste it directly in comment).
  • Launch Blender from the command line with --debug-gpu option and attach as text file here any error printed out in the console (do not paste it directly in comment).

System Information
Windows 10 Pro. Build 1803.
Intel Iris 540 GPU (Surface Pro 4).
Intel configuration assistant reports that all drivers are up to date.

Intel Iris 540 driver version 24.20.100.6136
Driver Date: 5/25/2018

Blender Version: 2.8 Alpha 2 (2018-09-10 build)

Ran (from console) blender --factory-startup

This was in the console:

found bundled python: C:\b\b\2.80\python
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFAF45F1F1D
Module : C:\WINDOWS\System32\DriverStore\FileRepository\64gh6136.inf_amd64_06bcc783578fcc06\ig9icd64.dll

Turned off OpenGL Depth Picking - no change.
Turned off Text anti-aliasing - no change in behavior (except the text, of course).
Turned off Region Overlap - no change.
Turned off 16 bit float textures - no change.
Turned off GPU mipmap generation - no change.
Changed "Images Draw method" from 2D texture to GLSL - no change.
Set texture limit size to "1024" - no change.

Note: Closing the preferences window will also cause the crash.
However, it's possible to save preferences, and reopen blender.

Ran blender with --debug-gpu.

Received same error above when resizing.
Note that numerous errors were generated during moving the window. attached as "debuggpu.txt"
Systeminfo.txt attached.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

Thanks.

@Clément Foucault (fclem) does this ring any bell?

Update: Latest 10/21/2018 drivers from Intel fix several rendering errors on Intel chipsets.

In addition, if you use these drivers, and manually turn OFF "Conservative Morphological Anti-Aliasing" in the Intel Graphics control panel, then Blender no longer crashes on resizing windows.

Clément Foucault (fclem) closed this task as Archived.Oct 31 2018, 7:50 PM

@Jaimi McEntire (Jaimi) Thanks for the heads up. We have our own AA methods and if Intel's option is crashing blender, it's not really our fault.

Do note that most of the rendering bugs are also gone because I implemented a workaround for them. So to find out if the driver fixes theses issue you need to test older blender 2.8 version or remove the fixes.

Closing this issue then.