Page MenuHome

2.8 crash on F12 then Shift-z
Closed, ArchivedPublic

Description

System Information
Windows 10
Intel(R) Core(TM) i5-3570S CPU @ 3.10GHz
Intel(R) HD Graphics 2500

Blender Version
Broken: 2.80 (sub 22), branch: blender2.8, commit date: 2018-09-20 00:19, hash: 2c30922e2c6,

Short description of error
Blender crashes on F12 then Shift-z combination

Exact steps for others to reproduce the error
Load default cube
Don't edit, move or anything else
press F12
Switch back to main Blender window
Press Shift-z
#CRASH#

However, it works when you press Shift-z immediately after loading, or you move things in the scene, then F12, then shift-z. It's also working fine on Intel(R) Core(TM) i7-6700T CPU @ 2.80GHz with Intel(R) HD Graphics 530

Also of note is the error when loading blender:
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
This appears for the Intel(R) Core(TM) i5-3570S CPU @ 3.10GHz Intel(R) HD Graphics 2500 machine AND the Intel(R) Core(TM) i7-6700T CPU @ 2.80GHz with Intel(R) HD Graphics 530
machine

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Cannot reproduce so far. What is the render engine you are using?

It's evee as default. It seems that it might be specific to the older intel CPU/GPU. A newer CPU/GPU doesn't give me this issue

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

This is most certainly the same issue as with T56855 then - 'old' intel GPUs that do not support officially anything past OpenGL 3.1… @flcem summoning you here too, you know whether this is not supported, WIP/known issue, or something else I guess…

I feared that, but at the same time, it _does_ work, just not for super complicated things (what things exactly, I'm trying to find out), and only if you do things in a certain order, as shown above. A few weeks ago nothing was rendering with these chipsets at all

This is very exciting as it means that #b3d101 school students can learn the basics on very old machines! The same machine was able to output this: https://twitter.com/peterejkemp/status/1042742860683063297

Just trying to show that T56853 isn't about memory size, the above steps are with the default cube and produce this:

C:\Users\peter.kemp\Desktop\blender-2.80.0-git.2c30922e2c6-windows64>blender.exe --debug-gpu
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Using KHR_debug extension
GL application marker: Successfully hooked OpenGL debug callback.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
found bundled python: C:\Users\peter.kemp\Desktop\blender-2.80.0-git.2c30922e2c6-windows64\2.80\python
GL API performance: Vertex shader recompiled due to state change.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFF6A1E6C81
Module : C:\Windows\SYSTEM32\ig7icd64.dll

Several of the Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported. have been dropped for readability.
Much more complex scenes do render (e.g. the spaceship)

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

We no longer support the Intel(R) HD Graphics 2500.
https://code.blender.org/2019/04/supported-gpus-in-blender-2-80/

However there is a good chance this was fixed in the meantime anyway.