Page MenuHome

2.8 crash on Intel processor
Closed, ArchivedPublic

Description

System Information
Intel(R) Core(TM) i5-3570S CPU @ 3.10GHz
Intel(R) HD Graphics 2500
Windows 10 - 64bit OS

Blender Version
2.80 (sub 22), branch: blender2.8, commit date: 2018-09-20 00:19, hash: 2c30922e2c6

Short description of error
Open Mr Elephant from https://www.blender.org/2-8/
Blender crashes blender when attempting to render it
Or select anything in the scene

Exact steps for others to reproduce the error
Download Mr Elephant from https://www.blender.org/2-8/
Try to render using F12 || click on scene using left or right click
#CRASH#

I have tried turning off Depth of Field, Bloom, Ambient Occlusion and Screen Space reflections, but it makes no difference
I can navigate the scene (albeit very slowly) using the middle mouse button
Evee rendering works for download of race_spaceship from https://www.blender.org/2-8/ if you turn off compositing in the post processing option (leaving this option on renders a transparent frame after appearing to render the whole spaceship.)

Of note is the error when loading blender:
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.

As mentioned above, I'm running a 64bit OS and the 64bit version of Blender

Details

Type
Bug

Event Timeline

Peter Kemp (peterejkemp) renamed this task from 2.8 crash on to 2.8 crash on Intel processor.
Bastien Montagne (mont29) triaged this task as Normal priority.

You may need to update your GPU drivers first of all? Also, HD2500 is only supposed to support OpenGL 3.1, iirc we require 3.2, @Clément Foucault (fclem)?

According to wikipedia the HD Graphics 2500 is OpenGL 4.0. Not sure if our drivers are up to date though, I'll try and get a look at the diagnostic tool for the OpenGL version.

@Peter Kemp (peterejkemp) We require opengl 3.3 core to be supported. The opengl version used for blender can be seen if you same the sysinfo.txt from the help menu. I would be nice to attach it to this repport too.

That said the win32 error maybe normal. Withotu the backtrace it's a little difficult to judge what's crashing. But if the viewport has no problem I think render should work.

System info attached. Struggling to get OpenGL version of the driver on this HD2500 GPU as I don't have the ability to install things on these machines.. Unless it's this:

renderer: 'Intel(R) HD Graphics 2500'
vendor: 'Intel'
version: '4.0.0 - Build 10.18.10.4252'

If this is to be believed, this means OpenGL 4.0
http://feedback.wildfiregames.com/report/opengl/device/Intel(R)%20HD%20Graphics%202500

Yes it seems to be oepngl 4.0.

Can you try running blender using the --debug-gpu option and see attach the output here?

C:\Users\peter.kemp\Desktop\blender-2.80.0-git.7deb38eec69-windows64>blender.exe --debug-gpu
Unable to create directory C:\Users\peter.kemp/.thumbnails/large/
Unable to create directory C:\Users\peter.kemp/.thumbnails/fail/blender/
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Using KHR_debug extension
GL application marker: Successfully hooked OpenGL debug callback.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
found bundled python: C:\Users\peter.kemp\Desktop\blender-2.80.0-git.7deb38eec69-windows64\2.80\python
GL API performance: Vertex shader recompiled due to state change.
GL API performance: Vertex shader recompiled due to state change.
Read blend: C:\Users\peter.kemp\Desktop\mr_elephant.blend
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.

[ATTEMPT TO RENDER WITH F12]

Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FFAD7DD7E37
Module : C:\Windows\SYSTEM32\ig7icd64.dll

So the crash is caused by the driver. We might be doing something wrong on our end or maybe the scene is already too big for that GPU (in the case the render subdiv level are different for render etc...).

It's difficult with so little info to guess what could be wrong.

It might be the scene size as the race_spaceship works and it's a smaller file. However, we're also getting a crash on rendering the default cube. I'll pull --debug-gpu on https://developer.blender.org/T56853

If it helps, this is the output for the spaceship:

C:\Users\peter.kemp\Desktop\blender-2.80.0-git.2c30922e2c6-windows64>blender.exe --debug-gpu
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
Using KHR_debug extension
GL application marker: Successfully hooked OpenGL debug callback.
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.
found bundled python: C:\Users\peter.kemp\Desktop\blender-2.80.0-git.2c30922e2c6-windows64\2.80\python
GL API performance: Vertex shader recompiled due to state change.
Read blend: C:\Users\peter.kemp\Downloads\race_spaceship.blend
GL API deprecated behavior: Wide lines have been deprecated. glLineWidth set to 2.000000. glLineWidth with width greater than 1.0 will generate GL_INVALID_VALUE error in future versions
Win32 Error# (3221692565): The specified OpenGL version and feature set are either invalid or not supported.

[lots of (2.00000 changes to difference values): GL API deprecated behavior: Wide lines have been deprecated. glLineWidth set to 2.000000. glLineWidth with width greater than 1.0 will generate GL_INVALID_VALUE error in future versions]
[and a few: Skipping auto-save, modal operator running, retrying in ten seconds...]

It renders as a transparent screen. Switching off compositing from the post-processing tab gives the same errors and renders as a complete model.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

We no longer support the Intel(R) HD Graphics 2500.
https://code.blender.org/2019/04/supported-gpus-in-blender-2-80/

However there is a chance this was fixed in the meantime anyway.