Page MenuHome

Spring weight paint bugs
Closed, ResolvedPublic

Description

Test file: lib/props/branches.blend from Spring.

  • Combined weight paint + pose mode is not working well:
    • Requires disabling Lock Object modes, which is not easy to discover.
    • When clicking on the armature to pick a bone, the mesh does not stay in weight paint mode.
  • X-ray modes does not work for the weight paint overlay, would be nice to be able to see weights on backsides.
  • Undo in weight paint mode with the brush tool active switches to the cursor tool in the topbar (but not the toolbar)
    • Still happens when undoing mode switching.
  • Paint through the mesh is not working (front facing only option?)
  • Select a bone should activate the vertex group for weight paint (not updating/redrawing?)
  • Rotation around selected user pref not working for bones (while in weight mode?)
  • Weight paint drawing has two issues:
    • There are Z-fighting issues with the weight paint overlay
    • Shading is not visible very well. Alpha can be reduced, but then it becomes hard to see the weights.
    • As a solution to both, the overlay could be multiplied rather than alpha blended?

Event Timeline

Brecht Van Lommel (brecht) renamed this task from Weight paint issues to Spring weight paint bugs.
Brecht Van Lommel (brecht) triaged this task as Normal priority.

The third issue is not related to bones.
It happens when you select the Vertex Group manually as well.

As soon as you start drawing the viewport will be updated.

Potential fix for the active-vertex-group-changed problem: D3716

The front facing option works like that:

Looks like what @Hjalti Hjálmarsson (hjalti) needs is the "2D Falloff" option that is in the same menu. And "Front Facing Only" needs to be turned off.

I got some crashes when testing but could not figure out what causes them yet. Looks like the "Paint through the mesh is not working" does not actually exist. It's just a matter of using the right settings.

Campbell Barton (campbellbarton) lowered the priority of this task from Normal to Needs Information from User.

"Combined weight paint + pose mode is not working well" could be it's own design task, since I'd like to know details of whats desired/expected.

It would be good to show an example that works well, what fails currently (is this working nicely in 2.7x? should we try bring back old behavior or solve differently)

Maybe only some small changes are needed too, for me this is too fuzzy still.

@Campbell Barton (campbellbarton), it appears you need to disable Lock Modes for this to work, and it's enabled by default. That for me is the main issue, it's difficult to discover.

D3890: Fix combined weight paint + pose mode not working well with `Lock Object Modes`. is intended to addresses that.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Nov 22 2018, 11:48 AM

Applied fixes to wpaint+pose mode.

So now it should be more or less usable.


Re: When clicking on the armature to pick a bone, the mesh does not stay in weight paint mode. - Not sure what is meant by this, was this ever the case or is it a suggestion for how it should work? In 2.7x this was also the case - when you don't lock modes selecting the object wont send it into pose mode in 2.7x or 2.8x. - It respects the mode the object already has.

I've noticed an issue that isn't mentioned here, that is the Z-key doesn't put bones in-front like it does in pose mode. Will look into this next.

Campbell Barton (campbellbarton) lowered the priority of this task from Normal to Needs Information from User.
Brecht Van Lommel (brecht) raised the priority of this task from Needs Information from User to Normal.

It seems to work well with the latest changes. You can select bone, paint, select bone, paint, ... without interruption.

Good to hear, closing.