Page MenuHome

Crash when scaling particle emitter during animation playback
Closed, ArchivedPublic

Description

System Information
OS: WIN10 64 Bit
GK: GTX 1070

Blender Version
Broken: Blender 2.80 Alpha 2; b350b194eb2

Short description of error
crash after scaling emitter of particles

Exact steps for others to reproduce the error
start playback with SHIFT+SPACEBAR
press S to scale object

Details

Type
Bug

Event Timeline

Can reproduce on Ubuntu 18.04.

# Blender 2.80 (sub 23), Commit date: 2018-09-25 07:38, Hash a933293f111

# backtrace
./blender(BLI_system_backtrace+0x35) [0x558f9413d58f]
./blender(+0x1a68f34) [0x558f92d98f34]
./blender(+0x1a69133) [0x558f92d99133]
/lib/x86_64-linux-gnu/libc.so.6(+0x3ef20) [0x7f9040565f20]
/usr/lib/x86_64-linux-gnu/libjemalloc.so.1(+0xc31e) [0x7f904191231e]
/usr/lib/x86_64-linux-gnu/libjemalloc.so.1(+0x292c7) [0x7f904192f2c7]
/usr/lib/x86_64-linux-gnu/libjemalloc.so.1(free+0x371) [0x7f904190a2d1]
./blender(MEM_lockfree_freeN+0x1dc) [0x558f943647ca]
./blender(+0x2a5364a) [0x558f93d8364a]
./blender(BKE_ptcache_id_clear+0x694) [0x558f93d85b86]
./blender(BKE_ptcache_id_reset+0x1cc) [0x558f93d865c7]
./blender(BKE_ptcache_object_reset+0x1e6) [0x558f93d867cd]
./blender(_ZSt13__invoke_implIiRPFiP5SceneP6ObjectiEJRS1_RS3_RiEET_St14__invoke_otherOT0_DpOT1_+0x64) [0x558f9416dec2]
./blender(_ZSt8__invokeIRPFiP5SceneP6ObjectiEJRS1_RS3_RiEENSt15__invoke_resultIT_JDpT0_EE4typeEOSB_DpOSC_+0x7e) [0x558f9416cc2f]
./blender(_ZNSt5_BindIFPFiP5SceneP6ObjectiES1_S3_iEE6__callIiJOP9DepsgraphEJLm0ELm1ELm2EEEET_OSt5tupleIJDpT0_EESt12_Index_tupleIJXspT1_EEE+0xaf) [0x558f9416b571]
./blender(_ZNSt5_BindIFPFiP5SceneP6ObjectiES1_S3_iEEclIJP9DepsgraphEiEET0_DpOT_+0x56) [0x558f94169834]
./blender(_ZNSt17_Function_handlerIFvP9DepsgraphESt5_BindIFPFiP5SceneP6ObjectiES5_S7_iEEE9_M_invokeERKSt9_Any_dataOS1_+0x37) [0x558f94166bc7]
./blender(_ZNKSt8functionIFvP9DepsgraphEEclES1_+0x49) [0x558f9417eb3d]
./blender(+0x2e4e1fe) [0x558f9417e1fe]
./blender(+0x2e0e3dc) [0x558f9413e3dc]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x76db) [0x7f90426bd6db]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x3f) [0x7f904064888f]

Could you give this report a better name please. E.g. "Crash when scaling particle emitter during animation playback". Thanks.

Jo (p34k) renamed this task from CrashBUG :-) to Crash when scaling particle emitter during animation playback.Sep 25 2018, 2:04 PM
Brecht Van Lommel (brecht) triaged this task as Confirmed, Medium priority.Sep 25 2018, 6:42 PM

I can't reproduce the bug in last 2.8 master. Can you confirm it is working for you too @Jo (p34k) in last 2.8 built from buildbot: https://builder.blender.org/download/ , and if it's working, can you change the status to resolved (Add Action >change status > resolved)? Thanks!

Ulysse Martin (youle) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Mar 8 2019, 8:10 AM

I triage this as incomplete as there was no feedback from the user. I think it has been solved. At least I can't reproduce it on my computer in last 2.8. Feel free to reopen it if you can still reproduce it in last 2.8 master

Philipp Oeser (lichtwerk) closed this task as Archived.
Philipp Oeser (lichtwerk) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.