Page MenuHome

Many (or all) links in Blender to addon documentation are broken
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Mac OS X Sierra
AMD FirePro D500 3072 MB

Blender Version


Broken: 2.79b
Worked: same version

Short description of error
Clicking the Documentation button, in an Addon's description in User Preferences | Addons, fails. Instead of linking to documentation, it links to a wiki page that reads "There is currently no text in this page. You can search for this page title in other pages, or search the related logs, but you do not have permission to create this page. "

Example link:
https://wiki.blender.org/wiki/Extensions:2.5/Py/Scripts

(I tested the first 12 addons listed today. All of their documentation buttons fail to link to documentation.)

Exact steps for others to reproduce the error

With *any* blend file open:
Go to User Preferences | Addons.
Expand the view of any addon.
Click the Documentation button.
See the wrong wiki web page load.
Done.

Details

Type
Bug

Event Timeline

Aaron Carlisle (Blendify) closed this task as Archived.
Aaron Carlisle (Blendify) claimed this task.

This is a known issue ever since we moved to the new wiki, and not really anything we can do except just saying that "It will be fixed in 2.8".
The documentation is still hosted temporally on https://en.blender.org/index.php/Extensions:2.6/Py/Scripts but this will be removed once we migrate the needed pages over to the new wiki.

Hello,

Thank for the subscription here and my apologize to not have been able to find this bug was already reported there before posting my version.

Is there very no way to make a quick redirection webpage which send to this https://en.blender.org/index.php/Extensions:2.6/Py/Scripts link instead of the error page ?!?
Or at least to add this temporary link within this error text within the actual error wiki page ? For instance something like this :
"There is currently no text in this page. You can search for this page title in other pages, or search the related logs, but you do not have permission to create this page."

It is very strange nowadays to believe there is no quick web redirection solution... I wonder what happens.

Anyway, thanks for the good work you do every day,
Cordially,
Guy

Sounds like the old pages need to be migrated, and possibly some redirects added, exactly like you just said above. IIRC, we've discussed this several times already? I assume you've finished migrating the old wiki? I could have sworn that's why I gave you the import/export access a month or two ago.

I imported all the release notes I think we agreed that we would not migrate addon docs as for 2.8 we wont have them on the wiki anyway.

Sounds like your mess. Please leave me out of this and future conversation. Thanks

Please also leave me out of this and future conversation. Thanks.

There was also T48096 and T54097, but to be honest: I am unaware of any 'final' decision on this...
Will also talk to @Campbell Barton (campbellbarton) again...

@Guy Capra (alomphega) : will remove you as a subscriber (hopefully this will be solved shortly...)