Page MenuHome

incorrect UV unwrap
Closed, ResolvedPublic

Description

System Information
Windows 10 64
i5-3470@3.2GHz
16 RAM
1050ti

Blender Version
Broken: 2.80 A2 60d4d583760
Worked: (2.79b) f4dc9f9d68b

Short description of error
I have pretty simple geometry. And Blender can't unfold it in UV correctly.

Exact steps for others to reproduce the error
Select the mesh - right click on mech
Enter edit mode - press Tab
Select all faces - press A
Make Unwrap - press U then select unwrap in popup menu
Change to any of two Methods in Unwrap settings window
See incorrect UVs in UV editor

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.Oct 4 2018, 4:10 PM
Philipp Oeser (lichtwerk) claimed this task.

If I understand correctly, this seems to be a selection/syncing problem of the UVEditor not selecting all UVs even if all are faces/verts are selected in the 3D view edit mode.

Unwrap itself seems to go fine if you go the extra mile and make sure you have all UVs really selected.
(so go into editmode, select all, go to UVEditor, select all again [selection should actually grow in your case test file], then unwrap)

Anyways, will have a look at code tomorrow (because this should work)

As of 3a1e9b9997e33c059d08138da707ac16490fddf7, UV selection syncing issues should be fixed.

I tried to redo the bug in 60d4d583760 and wasn't able to (changing settings always updates).

Philipp Oeser (lichtwerk) closed this task as Resolved.Oct 6 2018, 9:53 AM

Not sure what went wrong in my previous test, but I can also confirm selection syncing is working now

So as long as the Keep UV and edit mode selection in sync is turned on it should work well and unwrap should go fine.

@Valentin Pantyukh (ogneed) : Could you also confirm? (Feel free to reopen if issues persist, closing for now...)

Hi guys!
I just checked UV mapping -> Unwrap in last oficial Alpha — blender-2.80-55e3c17ccc1-win64.zip

Edit mode -> Select all faces ->UV mapping -> Unwrap

Now i see only thin UV line. I tried in all combination of the Angle Based\Conformal\Sync selection mode

Cannot reproduce, working fine here...

sorry for annoying you but take a look please https://yadi.sk/i/TpPjk-zzpGnbcA
this is video on yandex disk

I remember running into something similar. It was as if uv unwrap wouldn’t re-run if I already had a UV.

I reopened but I‘m yet to test the file and its reproduction steps, but the video matches what I ran into before. I will claim it, but @Philipp Oeser (lichtwerk) feel free to tackle it.

I've checked in last build (Hash: 134db5618ae)
All works fine for now. Thank you guys! You all doing great job!