Page MenuHome

Can't build blender on MacOS Mojave
Closed, ArchivedPublic

Description

System Information
MacOS X Mojave

Blender Version
Broken: 2.8 Branch on Mojave
Worked: 2.8 Branch on High Sierra

The build for 2.8 on MacOS Mojave failed due to a missing alc.h header file.

Exact steps for others to reproduce the error
$ make clean
$ make update
$ make

This yields all reasonable output until...

[ 19%] Built target extern_ceres
[ 19%] Building C object source/blender/editors/interface/CMakeFiles/bf_editor_interface.dir/interface.c.o
[ 19%] Building CXX object extern/audaspace/CMakeFiles/audaspace.dir/plugins/openal/OpenALReader.cpp.o
In file included from /Users/chuck/git/blender-build-2.8/blender/extern/audaspace/plugins/openal/OpenALReader.cpp:17:
/Users/chuck/git/blender-build-2.8/blender/extern/audaspace/plugins/openal/OpenALReader.h:31:10: fatal error:

'alc.h' file not found

#include <alc.h>

^~~~~~~

And eventually you see...

[ 19%] Linking C static library ../../../../lib/libbf_editor_io.a
make[3]: * [extern/audaspace/CMakeFiles/audaspace.dir/plugins/openal/OpenALReader.cpp.o] Error 1
make[3]:
* Waiting for unfinished jobs....
[ 19%] Building C object source/blender/editors/animation/CMakeFiles/bf_editor_animation.dir/anim_channels_edit.c.o
1 error generated.
make[3]: * [extern/audaspace/CMakeFiles/audaspace.dir/plugins/openal/OpenALDevice.cpp.o] Error 1
make[2]:
* [extern/audaspace/CMakeFiles/audaspace.dir/all] Error 2
make[2]: *** Waiting for unfinished jobs....

And finally...

make[1]: * [all] Error 2
make:
* [all] Error 2

Details

Type
Bug

Event Timeline

LazyDodo (LazyDodo) closed this task as Archived.Oct 5 2018, 8:00 PM
LazyDodo (LazyDodo) claimed this task.

from the bug report page

what not to report here
For Blender 2.8, please only report crashes. The bug tracker will be open for more general reports later.
Feature requests, see the developer contact page.
Compile or build issues, ask on #blendercoders or mail bf-committers.

that being said, feels like you either didn't checkout or did not complete the checkout of the svn libraries. see if lib/darwin/openal/include/AL/alc.h exists..

I had this exact issue, and I was able to resolve it by deleting the ../build_darwin_full folder and the ../lib folder and rerunning make update
Of note, the lib/darwin/openal/include/AL/alc.h did exist.

I believe the cause was upgrading either Xcode or MacOS.
Currently I'm running Xcode 11.1 and MacOS 10.15