Page MenuHome

Selection Sets not working with individual axis
Closed, ArchivedPublic

Description

System Information
Ubuntu 16.04
Operating system and graphics card
Platform Name: NVIDIA CUDA
Platform Vendor: NVIDIA Corporation
Platform Version: OpenCL 1.2 CUDA 9.0.368
Platform Profile: FULL_PROFILE
Platform Extensions: cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_copy_opts cl_nv_create_buffer
Number of devices: 1

		Device: #0
			Device Name: GeForce GTX 1080 Ti
			Device Vendor: NVIDIA Corporation
			Device OpenCL C Version: OpenCL C 1.2 
			Device Profile: FULL_PROFILE
			Device Version: OpenCL 1.2 CUDA
			Device Extensions: cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_copy_opts cl_nv_create_buffer

Blender Version
2.79b
Worked: (optional)

This report is regarding the add on: Bone Selection Sets version 2.1.1. I am not sure if this should be filed as a bug or a feature request.

Bone Selection Sets do not work when individual axis are selected. This is needed as a convenience for moving the avatar's COG bone, and its IK bones together as a unit in the Graph Editor. I need to make the same precise move in each Action Strip in the XY plane, hence need to quickly select the same axis in all IK bones in the Action Strip I am editing.

Exact steps for others to reproduce the error

  1. In the attached file open the Dope Sheet editor, and the Properties editor if these are not already open.

  1. In the Properties editor's Data tab expand the Selection Sets panel.
  2. In the Selection Sets panel left click the AvatarMoveX selection set. This does not have an bones in it yet.
  3. In the Dope Sheet expand ikElbowTargetLeft and iKwristRgiht to show the individual Location and Rotation axis.
  4. In each of the expanded bones select "X Location" using the Left Click and Shift Left click for simultaneous selection.
  5. In the Selection Sets panel click on Assign. Then click on Deselect. The selected bone axis will not be deselected, indicating they were not added to the selection set.

If this is not a bug please consider the ability to add a bone's individual axis to a Selection Set a feature request.

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Normal priority.

Oops, I missed the notification for this task. Sorry about that, I'll make time for it this week!

Hi @Adam Preisler (Alphisto)
As far as I can understand, you want to assign individual bone transform channels to sets?
This isn't possible and there are no plans for it, atm.

I tried adding a bone to a set by clicking one of its transform channels on the DopeSheet and that worked for me on Blender 2.79.

The set "AvatarMoveX" does have bones assigned to it, maybe this caused the confusion? (the UI is not the best)

Inês Almeida (brita_) lowered the priority of this task from Normal to Incomplete.Mon, Nov 19, 11:33 AM

Oops, yes.
Setting task to "incomplete" until there is something concrete to act on.

Bastien Montagne (mont29) closed this task as Archived.Mon, Dec 3, 4:30 PM

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.