Page MenuHome

Mesh Subdivide with smoothness is coordinate dependent
Closed, ArchivedPublic

Description

System Information
Windows 7 Professional 64-bit service pack 1
Intel Core i7-2600
8GB RAM
NVIDIA GTX 1060 6GB

Blender Version
Broken:
2.79b f4dc9f9d68b
2.80 Alpha 2 db1a04313c3

Short description of error
Mesh Subdivide with smoothness is coordinate dependent although it shouldn't be.

Exact steps for others to reproduce the error
Apply mesh subdivide with smoothness > 0 and high enough number of cuts.
Proper result is all meshes to be have identical shape but actually they all be differently.

Note: I cannot judge whether this issue is caused by same reason as T57103 or not, so i decided to report this separately.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Can confirm this (although I am not sure this is solvable easily)
`
Subdivide smooth depends on vertex normals. These are mostly fine when having meshes with faces but are more "problematic" in edge-only meshes.
(you can inspect these with the Normals Overlay)

So as a workaround you could extrude the edges just a little in Z (note how the normals are much more "predictable" now), subdivide smooth then, and get rid of the extra edgeloop afterwards.

I would have to dig a little deeper on how blender actually calculates normals for edge-only meshes (not sure if this be improved even theoretically).
Or think about another workaround.

maybe @Campbell Barton (campbellbarton) can comment?

Confirming/Claiming for now (so it doesnt get lost)

Philipp Oeser (lichtwerk) closed this task as Archived.Feb 1 2019, 11:11 PM

So while this would be nice to support, it is not a bug - I'll quote from another report here:

Taking into account vertex normals for vertices and edges could be useful, but that's a missing feature that would be nice to add, not a bug.

Will archive this then...