Page MenuHome

Crash displaying toolbar tooltips
Closed, ResolvedPublic

Description

System Information
FreeBSD 11.2 64bit - nvidia GT730

Blender Version
Broken: Blender2.8 - 9/10/18 - e7218e704997
System compiler is clang 6.0.1

Short description of error
Blender crashes when displaying tooltips for toolbar items, other tooltips are OK

(lldb) run --factory-startup
Process 32040 launching
Process 32040 launched: '/home/shane/Projects/blender-bits/blender-280/umfbuild/bin/blender' (x86_64)
Process 32040 stopped
* thread #1, name = 'blender', stop reason = signal SIGSEGV: invalid address (fault address: 0x8)
    frame #0: 0x00000008036b25b3 libpython3.7m.so.1.0`PyDict_GetItem + 19
libpython3.7m.so.1.0`PyDict_GetItem:
->  0x8036b25b3 <+19>: movq   0x8(%rbx), %rax
    0x8036b25b7 <+23>: testb  $0x20, 0xab(%rax)
    0x8036b25be <+30>: je     0x8036b266f               ; <+207>
    0x8036b25c4 <+36>: movq   0x8(%r14), %rax
(lldb) bt
* thread #1, name = 'blender', stop reason = signal SIGSEGV: invalid address (fault address: 0x8)
  * frame #0: 0x00000008036b25b3 libpython3.7m.so.1.0`PyDict_GetItem + 19
    frame #1: 0x00000008036b6845 libpython3.7m.so.1.0`PyDict_GetItemString + 37
    frame #2: 0x0000000000e175c6 blender`PyC_RunString_AsString [inlined] PyC_MainModule_Backup at py_capi_utils.c:742
    frame #3: 0x0000000000e175ad blender`PyC_RunString_AsString(imports=0x00007fffffffdd40, expr="bl_ui.space_toolsystem_common.description_from_name(bpy.context, bpy.context.space_data.type, 'Transform') + '.'", filename="<expr as str>", r_value=0x00007fffffffdd00) at py_capi_utils.c:1204
    frame #4: 0x0000000000de0f8c blender`BPY_execute_string_as_string(C=0x000000082e415708, imports=0x00007fffffffdd40, expr="bl_ui.space_toolsystem_common.description_from_name(bpy.context, bpy.context.space_data.type, 'Transform') + '.'", verbose=true, r_value=0x00007fffffffdd00) at bpy_interface.c:644
    frame #5: 0x0000000000c1c341 blender`UI_tooltip_create_from_button at interface_region_tooltip.c:422
    frame #6: 0x0000000000c1c21e blender`UI_tooltip_create_from_button(C=<unavailable>, butregion=0x000000082f882c88, but=<unavailable>, is_label=<unavailable>) at interface_region_tooltip.c:1241
    frame #7: 0x0000000000a56545 blender`WM_tooltip_init(C=0x000000082e415708, win=0x000000082f839688) at wm_tooltip.c:123
    frame #8: 0x0000000000a37212 blender`wm_event_do_handlers(C=<unavailable>) at wm_event_system.c:2986
    frame #9: 0x0000000000a31c90 blender`WM_main(C=0x000000082e415708) at wm.c:412
    frame #10: 0x0000000000a2de03 blender`main(argc=2, argv=0x00007fffffffe370) at creator.c:525
    frame #11: 0x0000000000a2d814 blender`_start + 148

Details

Type
Bug

Event Timeline

Obviously something wrong, but I cant seem to be able to reproduce...
Do you mean these?:

Have you tried a build from https://builder.blender.org/download?

Yes, and only those tooltips fail, so some variation with the toolbar? The first line does show, it fails both with py and dev tips on and off.

There are no official builds available for freebsd. I am linking with python 3.7.0 and also tried 3.7.1rc1

Sorry about the freebsd builds comment...
Hm, linking 3.7.0 as well.

Apparently getting the tip makes a python detour from C (see here), but my unexperienced eyes dont see whats going wrong with the built expression there...

@Campbell Barton (campbellbarton) : could you take over?

I can't redo this on Linux, from the stack trace it looks like it's failing on the call:

PyDict_GetItemString(interp->modules, "__main__")

With an error converting "__main__" to a Python string.

I would guess something about Python's internal state has become corrupt/invalid, but would need to be able to redo the bug to look into it further.

Does this happen on other FreeBSD systems too?

Update, tried on FreeBSD and all tooltips display without crashing in object and editmode, brief and extended:

  • Blender 9b5183769b869a4a69488d1fc073f175fa1f1b74
  • clang --version:

    FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) (based on LLVM 6.0.0)
  • uname -a

    FreeBSD freebsd 11.2-RELEASE FreeBSD 11.2-RELEASE #0 r335510: Fri Jun 22 04:32:14 UTC 2018
  • python3.7 --version

    Python 3.7.0 (default, Oct 2 2018, 04:59:56)
Shane Ambler (sambler) closed this task as Resolved.Oct 21 2018, 4:43 AM

I got it working last night, but I can't figure out what change fixed it.