Page MenuHome

Crashing with extrusion tool (Blender 2.8, Windows 10)
Closed, ResolvedPublic

Description

System Information
CPU: Ryzen 2500U
GPU: Vega 8
RAM: 8GB
OS: Windows 10 Home 64bit 1803

Blender Version
Broken: Blender 2.8 (blender-2.80-1dd3b93d2f9-win64)

Short description of error
Occasionally while using the extrude tool in edit mode with snapping to vertice, edges, faces or volumes on, Blender will crash.

Details

Type
Bug

Event Timeline

Dalai Felinto (dfelinto) triaged this task as Needs Information from User priority.Oct 10 2018, 4:38 PM

I can't reproduce this here. Please attach the system crash log.

According to blender documentation, crash logs on Windows are disabled. https://docs.blender.org/manual/en/dev/troubleshooting/crash.html

Are you able to suggest where I could find it for Blender 2.8 for Windows.

This comment was removed by Alaska (Alaska).
Alaska (Alaska) added a comment.EditedOct 11 2018, 1:15 AM

I ran Blender in --debug-all mode. This is the error for the crash I experienced:

wm_event_do_handlers: Handling event
wmEvent  type:101 / E, val:1 / PRESS,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(1055,769), ascii:'e', utf8:'e', keymap_idname:(null), pointer:000002295B33FCB8
DEG::`anonymous-namespace'::deg_graph_id_tag_update: id=MEPlane.003 flags=GEOMETRY
DEG::`anonymous-namespace'::deg_graph_id_tag_update: id=MEPlane.003 flags=GEOMETRY
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF6E97A4BA8
Module  : C:\Users\Alaska\Desktop\blender-2.80.0-git.1dd3b93d2f9-windows64\blender.exe
Address : 0x00007FF6E97A4BA8
Module  : C:\Users\Alaska\Desktop\blender-2.80.0-git.1dd3b93d2f9-windows64\blender.exe

I decided to run the same test on all the versions of Blender 2.8 I had on my computer as I've noticed that later versions were more reliable. Turns out every version I had experienced this issue with the exact same error report. The only difference being the address, but I'm putting that down to the fact that the address is probably in RAM which means it can change quite a bit.

The versions I had for testing are:
29c2c307f6e - September 10th
6f42eb245b1 - September 27th
9b49a0d971c - October 8th
1dd3b93d2f9 - October 10th

I've found another factor that needs to be activated for this crash to occur. Snapping to an object. At the moment my tests have shown that increment snapping is unaffected. However, vertices, edges, faces, and volumes show this issue.

I'll add this to the original post for anyone that stumbles across this.

Cannot reproduce still.

Please always attach a small and simple .blend file to help reproducing the issue, always saves us a tremendous of time.

Alaska (Alaska) added a comment.EditedOct 25 2018, 9:40 AM

I've just updated to blender-2.80-bf34f95a9ed (October 25th) and the issue persists.

As for providing a file, the startup file shows this issue along with every other file I've worked on such as this one:

Here's a video of the issue occurring: https://youtu.be/8BshcKbHn9k
I know it's an odd case, constantly extruding something until the software crashes, but this just seems to occur at random times while working on projects such as in the file provided above.

Same sort of error code:

wm_event_do_handlers: Handling event
wmEvent  type:101 / E, val:1 / PRESS,
         shift:0, ctrl:0, alt:0, oskey:0, keymodifier:0,
         mouse:(897,644), ascii:'e', utf8:'e', keymap_idname:(null), pointer:00000167D53D8F58
DEG::`anonymous-namespace'::deg_graph_id_tag_update: id=MECube flags=GEOMETRY
DEG::`anonymous-namespace'::deg_graph_id_tag_update: id=MECube flags=GEOMETRY
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF659449B50
Module  : C:\Users\Alaska\Desktop\blender-2.80.0-git.bf34f95a9ed-windows64\blender.exe
Alaska (Alaska) added a comment.EditedOct 25 2018, 8:45 PM

It's possible this issue is limited to APU's (The GPU and CPU share RAM and the error is an inability to access something from RAM from what I can tell) or Windows. I currently don't know how to install another operating system so I can't test that. However, I'm upgrading my secondary PC to a separate CPU (R5 2600) and GPU (RX 570) setup in a few days, so hopefully I can test the APU hypothesis.

Note: The secondary system currently runs a A6 9500 APU on Windows 10 and also experiences this issue.

The issue persists with a discreet GPU and CPU on blender-2.80-c750ebe113e (October 29th).

I seem to be able to repro here -- indeed it looks related to snapping.

em->looptris is bogus in the below codepath. See line 862 of bvhutils.c which leads to crash on line 875.

blender.exe!bvhtree_from_editmesh_looptri_create_tree(<snip>) Line 875	C
blender.exe!bvhtree_from_editmesh_looptri_ex(<snip>) Line 987	C
blender.exe!raycastEditMesh(<snip>) Line 607	C
blender.exe!raycastObj(<snip>) Line 752	C
blender.exe!raycast_obj_cb(<snip>) Line 809	C
blender.exe!iter_snap_objects(<snip>) Line 232	C
blender.exe!raycastObjects(<snip>) Line 876	C
blender.exe!transform_snap_context_project_view3d_mixed_impl(<snip>) Line 2642	C
blender.exe!ED_transform_snap_object_project_view3d_ex(<snip>) Line 2749	C
blender.exe!ED_transform_snap_object_project_view3d(<snip>) Line 2782	C
blender.exe!snapObjectsTransform(TransInfo * t, const float * mval, float * dist_px, float * r_loc, float * r_no) Line 1231	C
blender.exe!CalcSnapGeometry(TransInfo * t, float * UNUSED_vec) Line 967	C
blender.exe!applySnapping(TransInfo * t, float * vec) Line 427	C
blender.exe!applyTranslation(TransInfo * t, const int * UNUSED_mval) Line 4968	C
Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Nov 22 2018, 11:45 AM

Still cannot reproduce :/

Could be windows thing, maybe?

I'm still capable of reproducing this bug in recent versions. Probably is a Window's thing then.

I'm no longer able to reproduce this bug in Blender 2.8 565de7750b9. However, I'll leave this open and let the developers decide whether or not to close this report.

Alaska (Alaska) closed this task as Resolved.Dec 1 2018, 11:55 PM
Alaska (Alaska) claimed this task.