Page MenuHome

Sculpt Simplify Brush breaks menus and causes odd behavior.
Closed, ArchivedPublic

Description

This bug may be related. https://developer.blender.org/T52780

Manjaro KDE Linux 10.10.18

Blender 2.8 10.10.18 and 2.79b

Nvidia GTX 580

The sculpt simplify brush has no entry in the main brush picture menu. This causes odd menu behavior like changing the icons to other icons when you select it through the text menu system. May have also crashed blender but this might also have been and undo fail, could not reproduce that problem.

Sculpt->Brush->Sculpt tool->Simplify.

Was stated in the other bug report that the use case was unknown. I find it useful when I have dynamic set to a small number like 2 and then have to many verts thus a slow down. You can change it to 8 and go over your work to change the mesh density back up to something workable.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

The Brush workflow is being changed in T56744: Proposal: Improving Brush Workflow in Blender, and the new design should resolve this problem, by putting all the tools in the toolbar (which would include simplify) rather than the brushes.

For now this should be considered a work in progress.

Note that select the Simplify tool through the menu does not select a different brush, rather it changes the current brush to use a different tool which then also changes the icon. The new design is intended to avoid that confusion.