Page MenuHome

Blender keeps packed textures in sRGB color space
Closed, ArchivedPublic

Description

System Information
Windows 10 Pro, 64-bit.

Blender Version
blender-2.79-6e08b01bd9a-win64

Short description of error

I model various assets and texture them with Substance Painter. In order to upload the models to Gumroad etc. I choose "Automatically pack into .blend" and pack all the textures and HDRI inside the blend file. When this file is opened again in its packed version, then when I press Shift+Z for real time rendering, then the models appear strangely glossy or with surface artifacts. I searched a bit and I found out that the problem lies in the node editor's properties panel on the right (N key). Despite the fact that all image texture nodes for roughness, bump and normal are set to "non-colour data", the properties panel keeps the "sRGB EOTF" value and makes the packed textures appear strange. The problem is solved in two ways:

  1. Change the value to non-colour by hand, or
  2. Unpack all textures to a new file.

I upload a PrtScn with a red highlight at the problematic areas.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

There are indeed two separate color management settings, one on the node and one on the image. This is confusing and should be fixed, it's a known TODO item: T54659: Move and share Eevee / Cycles render settings.

Thank you Brecht. I thought I was doing something wrong.