Page MenuHome

Number value fields are missing multiple object support.
Closed, InvalidPublic

Description

Blender Version
Broken: example: 2.79

when editing multiple key frames or multiple objects at once, blender shows only the values for the active element.

When the user types "0.5", only the active object is receives the value and the rest of the selection is ignored.
This is counter intuitive and causes a lot of redundant work

Additionally, power users or animators from other systems will want to type in an expression to any value field with multiple objects selected, i.e. selecting multiple objects with different scales and entering "*=0.5" would scale all selected objects by half.

without this core feature of value entry fields, adjusting every value across blender is that much slower.

Exact steps for others to reproduce the error

1: set 100 keyframes on something.
2: in the graph editor, select all keys, "a".
3: using "t" hotkey and set all keyframe interpolation to be elastic
4: using the properties sidebar "n", set all the selected keyframes to have the elastic amplitude of 0.5

problem: what should have been one operation now must be done in 300+ operations.

note how sore your wrist gets. ;)

ideal usage.
typing "0.5" should set all the selected keyframes elastic amplitude to that value.
typing "+=0.5" should add that value to all the selected keyframes elastic amplitude.
typing "*=0.5" should multiply all the selected keyframes elastic amplitude values by half.

Details

Type
Bug

Event Timeline

Not sure here but have you trying holding ALT before clicking into the number field and then typing it? There is sort of a hidden feature in Blender that if you hold down ALT the action gets performed for all selected. But that does not work completely consistently (probably why it's hidden) so it might not work here.

Looks like this is mixing muliple object prop editing with multiple keyframe editing?

The former is indeed implemented to some degree as @Adam Preisler (Alphisto) mentioned (alt+click on a property).
There is also T54862 [which is not really implemented as suggested afaics], so maybe @Dalai Felinto (dfelinto) or @William Reynish (billreynish) could comment?

Anyways, this was not intended to work on multiple keyframes (opposed to multiple objects), so I guess this is not a bug, more of a feature request?

Regarding the relative expression input [e.g =+2] also isnt finished as intended afaics...

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

Thanks for the suggestion, but we do not accept feature requests or suggestions on this tracker (use forums or bf-funboard ML for that).