Page MenuHome

does not see openCL
Closed, ArchivedPublic

Description

System Information
ubuntu16.04.05;AMD_VEGA_RX_64 x 2; systemboard Biostar Racing X370GT7: CPU AMD Ryzen 3 1300X
AMD_GPU_PRO 18.30 for 16.04

Blender Version
2.78c, 279b, 2.8

Short description of error
does not see the openCL

Exact steps for others to reproduce the error
clear system OS+drivers
clinfo = ok

p.s. on another motherboard am3+ MSI_990FXA-GD80 with CPU AMD8350FX sees and works

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.
  • Please:
    • Attach the output of clinfo, maybe it gives some clues for how this is different.
    • Run blender --debug-cycles -b -E CYCLES -f 1 in the terminal and attach the output.


clarification of the situation BLENDER invisible OPEN_CL if there are more than one device

Hi guys! clearing up! the BLENDER does not see the OpenCL with several devices with drivers 18.30 and 18.40; and with drivers 18.20 and below it sees and works. How can I help with the solution of this sore?

Are you saying that if there are multiple GPUs connected, it does not detect any GPU at all? Or it just detects one? And to be clear, by "invisible" you mean does not show up under User Preferences > System > Compute Device > OpenCL?

It's a little confusing because the debug log seems to indicate the GPU is being detected, so it's not immediately obvious to me at what stage the issue happens.

Can you attach the output of running clinfo with the 18.20 drivers, where it did work? If the output is different than 18.30/40, that might give us a clue.

Yes, this is not displayed in the section “User Settings”> “System”> “Compute Device”> “OpenCL” and add-on/Render/Render:Cycles Render Engine Preferences

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

Seems information was given here, putting back to "Needs Triage".
(Comparing the two clinfo, I cant spot anything that catches my eye... but maybe @Brecht Van Lommel (brecht) knows more...)

@maxim (adrfray) I have been looking into this issue, but am not able to detect any stange things. Can you add a video where you show the issue.
It also seems to me that the 18.20 drivers are not using the GPU's are you sure that OpenCL was enabled and your user preferences were saved?

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Mar 21 2019, 12:52 PM
Bastien Montagne (mont29) closed this task as Archived.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.