Page MenuHome

Crash when trying to paint after editing mode
Closed, ResolvedPublic

Description

System Information
Windows 10, Nvidia Geforce 960

Blender Version
Broken: 2.80 Alpha 2 (2018-10-23)
Worked: (optional)

Short description of error
Crashes when I try to paint textures after edit the UVs.

Exact steps for others to reproduce the error
I paint a simple cube. Then I edit the UVs. When I try to paint again over the cube Blender crashes.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.Oct 25 2018, 10:01 AM
Philipp Oeser (lichtwerk) claimed this task.

Please always provide a simple blend file with exact steps to reproduce the error (description was a bit vague here)

Anyways, could reproduce doing the following:

  • open file
  • (enter texture paint mode)
  • do a stroke
  • enter editmode
  • enter texture paint mode again
  • do another stroke --> crash
1  project_paint_face_paint_slot   paint_image_proj.c 476  0x1ff787c 
2  project_paint_prepare_all_faces paint_image_proj.c 3680 0x2002469 
3  project_paint_begin             paint_image_proj.c 3889 0x2002df1 
4  paint_proj_new_stroke           paint_image_proj.c 5220 0x2006e13 
5  texture_paint_init              paint_image.c      475  0x1febfd9 
6  paint_stroke_test_start         paint_image.c      636  0x1fec71a 
7  paint_stroke_modal              paint_stroke.c     1217 0x2013a53 
8  paint_invoke                    paint_image.c      656  0x1fec7c8 
9  wm_operator_invoke              wm_event_system.c  1323 0x1a0a095 
10 wm_handler_operator_call        wm_event_system.c  2057 0x1a0be74 
11 wm_handlers_do_intern           wm_event_system.c  2359 0x1a0c8b5 
12 wm_handlers_do                  wm_event_system.c  2619 0x1a0d46e 
13 wm_event_do_handlers            wm_event_system.c  3073 0x1a0e933 
14 WM_main                         wm.c               412  0x1a03bfe 
15 main                            creator.c          525  0x19fea1c

ProjPaintState->mpoly_eval seems to have garbage at first sight, will investigate...

also got two related crashes while testing (just posting here as a reference for possible related issues... think the difference to the backtrace above was just switching to MATERIAL viewport prior to first stroke...)

1  project_paint_prepare_all_faces paint_image_proj.c 3743 0x200277b 
2  project_paint_begin             paint_image_proj.c 3889 0x2002df1 
3  paint_proj_new_stroke           paint_image_proj.c 5220 0x2006e13 
4  texture_paint_init              paint_image.c      475  0x1febfd9 
5  paint_stroke_test_start         paint_image.c      636  0x1fec71a 
6  paint_stroke_modal              paint_stroke.c     1217 0x2013a53 
7  paint_invoke                    paint_image.c      656  0x1fec7c8 
8  wm_operator_invoke              wm_event_system.c  1323 0x1a0a095 
9  wm_handler_operator_call        wm_event_system.c  2057 0x1a0be74 
10 wm_handlers_do_intern           wm_event_system.c  2359 0x1a0c8b5 
11 wm_handlers_do                  wm_event_system.c  2619 0x1a0d46e 
12 wm_event_do_handlers            wm_event_system.c  3073 0x1a0e933 
13 WM_main                         wm.c               412  0x1a03bfe 
14 main                            creator.c          525  0x19fea1c
1  BLI_linklist_prepend_nlink        BLI_linklist.c     173  0x2ca01d0 
2  BLI_linklist_prepend_arena        BLI_linklist.c     186  0x2ca026e 
3  project_paint_bleed_add_face_user paint_image_proj.c 3390 0x200171f 
4  project_paint_prepare_all_faces   paint_image_proj.c 3674 0x200241c 
5  project_paint_begin               paint_image_proj.c 3889 0x2002df1 
6  paint_proj_new_stroke             paint_image_proj.c 5220 0x2006e13 
7  texture_paint_init                paint_image.c      475  0x1febfd9 
8  paint_stroke_test_start           paint_image.c      636  0x1fec71a 
9  paint_stroke_modal                paint_stroke.c     1217 0x2013a53 
10 paint_invoke                      paint_image.c      656  0x1fec7c8 
11 wm_operator_invoke                wm_event_system.c  1323 0x1a0a095 
12 wm_handler_operator_call          wm_event_system.c  2057 0x1a0be74 
13 wm_handlers_do_intern             wm_event_system.c  2359 0x1a0c8b5 
14 wm_handlers_do                    wm_event_system.c  2619 0x1a0d46e 
15 wm_event_do_handlers              wm_event_system.c  3073 0x1a0e933 
16 WM_main                           wm.c               412  0x1a03bfe 
17 main                              creator.c          525  0x19fea1c
Philipp Oeser (lichtwerk) renamed this task from Closes when trying to paint after editing mode to Crash when trying to paint after editing mode.Oct 25 2018, 10:01 AM

@Philipp Oeser (lichtwerk) not sure if this is related ,but I never posted cause I never could 100% reproduce.

#1 Add particle system to default cube and set emitter to hair with a low number(like 25) to start with.
#2 Enter Particle Edit mode, select "Add" from toolshelf, and add more particles.
#3 Enter Edit mode.
#4 Repeat steps #2 and #3 until blender crashes.
Philipp Oeser (lichtwerk) closed this task as Resolved.Feb 1 2019, 11:04 PM

Cannot reproduce this anymore (as of rB9a63fa21eb45),
Havent tracked down the exact commit, but will consider this resolved.

(Feel free to comment again though if issues persist...)