Page MenuHome

Undesirable deformation when applying bezier curve
Closed, InvalidPublic

Description

System Information
Windows 8.1 Pro. integrated graphics card
Lap Top Standard

Blender Version
Broken:

version: 2.79 (sub 0), branch: master, commit date: 2018-03-22 14:10, hash: f4dc9f9d68b, 
type:
build date: Thu 03/22/2018, 09:59 AM
platform: Windows 8.1 Pro.

binary path: 'C:\\Program Files\\Blender Foundation\\Blender\\blender.exe'
build cflags: /W3 /w34062 /wd4018 /wd4146 /wd4065 /wd4127 /wd4181 /wd4200 /wd4244 /wd4267 /wd4305 /wd4800 /we4013 /we4431 /DWIN32 /D_WINDOWS /W3 /nologo /J /Gd /MP /openmp
build cxxflags: /W3 /w34062 /wd4018 /wd4146 /wd4065 /wd4127 /wd4181 /wd4200 /wd4244 /wd4267 /wd4305 /wd4800 /we4013 /we4431 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /nologo /J /Gd /MP /EHsc /openmp
build linkflags: /MACHINE:X64 /SUBSYSTEM:CONSOLE /STACK:2097152 /INCREMENTAL:NO /NODEFAULTLIB:msvcrt.lib /NODEFAULTLIB:msvcmrt.lib /NODEFAULTLIB:msvcurt.lib /NODEFAULTLIB:msvcrtd.lib /ignore:4049 /ignore:4217 /ignore:4221
build system: CMake

Python:

version: 3.5.3 (default, May 20 2017, 19:10:40) [MSC v.1800 64 bit (AMD64)]
paths:
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\scripts\\addons_contrib'
'C:\\Users\\User\\AppData\\Roaming\\Blender Foundation\\Blender\\2.79\\scripts\\addons'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\scripts\\addons'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\scripts\\startup'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\scripts\\modules'
'C:\\Program Files\\Blender Foundation\\Blender\\python35.zip'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\python\\DLLs'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\python\\lib'
'C:\\Program Files\\Blender Foundation\\Blender'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\python'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\python\\lib\\site-packages'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\scripts\\freestyle\\modules'
'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\scripts\\addons\\modules'
'C:\\Users\\user X\\AppData\\Roaming\\Blender Foundation\\Blender\\2.79\\scripts\\addons\\modules'
'C:\\Users\\user X\\AppData\\Roaming\\Blender Foundation\\Blender\\2.79\\scripts\\addons\\code_autocomplete-master\\jedi'
'C:\\Users\\user X\\AppData\\Roaming\\Blender Foundation\\Blender\\2.79\\scripts\\addons\\code_autocomplete-master\\autocompletion\\suggestions\\dynamic'

Python (External Binary):

binary path: 'C:\\Program Files\\Blender Foundation\\Blender\\2.79\\python\\bin\\python.EXE'
version: Python 3.5.3

4b206af, see splash screen)

Worked: (optional)

Short description of error
How is this deformation avoided, when applying the curve modifier, between a rectangle and a bezier curve?


for me this is a programming error, in consequence it is a bug !!!
because they have never repaired it or because they have never given an alternative solution?

If my model is for mechanical engineering, this does not work for me, this software will not give me a rough simulation of what can happen with the mechanics of a caterpillar

Exact steps for others to reproduce the error
1- remove everything from the 3D view
2- create a cube, scale in z
3- create a bezier curve
4- apply array modifier
5- fit type: fixed court

count: 16
Relative offset: 1.215

6- apply curve modifier (circle) BezierCircle

Object: BezierCircle
deformation axis: X

I am very sorry if I am a nuisance or my question and opinion bothers me, but I have been trying to figure out how to avoid this, I spent the year exhausting the resources of the cloud like free courses, questions in stack exchange, its useless and useless user manual, its complicated and poor explanation of the blender api python, ask in forums, ask in blender communities, look in books, in blender specialized magazines, ask supposed experts of the modeling medium, and I could not get a satisfactory answer, since they do not have the solution or just did not answer.

please diculpen my opinion but I am sincere, I believe that it is to express the things that one sees badly to improve them and not to bother them, otherwise how could one fix something of which a sincere opinion is not known?

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) closed this task as Invalid.
Philipp Oeser (lichtwerk) claimed this task.

You dont wont to have an array that is curve deformed here, you are better of rigging this differently.
Goal is to have a bunch of individual objects following the curve/path.

As a start: remove the array modifier, remove the curve modifier, duplicate the Cube.001 16 times and set up Follow Path constraints with incrementing offsets o them. There are more involved techniques using drivers etc. as well, but this tracker is for bugs only and not a support forum...

Anyways, this is not a bug, closing...

hello Philipp Oeser (lichtwerk)

thanks for answering
It may be my lack of experience in this field, what is considered an error or an error in some things, applying different techniques for a goal that can happen to 2 things.
1 reach that goal with certain tools what it requires, as a law and not as a theory.

2 that the defects of the tools have to structure a technique that solves the lack of good functioning. And that's what you can do to find a cluster of steps.

On the other hand, I did not come to learn to model, my question was very precise, because this does not work correctly. because it is not detailed in the source code, the answers can be simple, because they do not feel like it, because nobody is worried about doing it, because nobody bothered that detail and just do not do it, or because it can not be limited of programming or programmers.
also clarify that I had already exhausted the instances and communities asking how to solve this, I never had answers, they simply told me that this is what it does and that it is a defect that has no solution.

Maybe it is annoying that someone considers an error something that does not affect you because they solve it by working with more steps in your modeling technique, but it is an error of your calculations in math.

I appreciate your response.

You dont wont to have an array that is curve deformed here, you are better of rigging this differently.
Goal is to have a bunch of individual objects following the curve/path.
As a start: remove the array modifier, remove the curve modifier, duplicate the Cube.001 16 times and set up Follow Path constraints with incrementing offsets o them. There are more involved techniques using drivers etc. as well, but this tracker is for bugs only and not a support forum...
Anyways, this is not a bug, closing...

Can you prove to me that it is not an error, according to your steps in your modeling technique ?, so I am convinced that it is not or what is a mistake. I also want to clarify that there is nothing in my life, I simply defend my convictions based on facts, and I also accept other positions and opinions based on facts that can be confirmed

The Curve modifier is a deforming modifier, it will not preserve the shape of your object, it is specifically made to deform your object along a curve (and take the shape of the curve).
When using a deforming modifier [the ones that are under the Deform category], there is no way that this "deformation can be avoided".

I pointed you to another technique (using constraints) that will still follow a curve, but doesnt deform your shape, because I wanted to help and assumed that is what you are after.
Other than that, I'm afraid I cant help you further.