Page MenuHome

Volumetric shaders and Subsurface Scattering not rendering on AMD GPU / OpenCL
Closed, ArchivedPublic

Description

System Information
iMac Pro 8core Vega 64
MacOS 10.13.6

Blender Version
Blender 2.97b
Blender 2.80 alpha2

Dear developers, according to
https://docs.blender.org/manual/en/dev/render/cycles/features.html# and https://wiki.blender.org/wiki/Def:Ref/Release_Notes/2.79#Cycles_Rendering
GPU rendering should already work with all features.
But at least on my system Subsurface Scattering and Volumetric effects do not show up in render output when rendering on GPU.
CPU rendering works.

On Blender 2.8 using hybrid rendering, the tiles do not match because the ones rendered by GPU do not show SSS.

Please see attached files:
System info
startup_cube_volume_absorption_gpu
startup_cube_volume_absorption_cpu
startup_cube_sss_gpu
startup_cube_sss_cpu
screenshot of hybrid rendering on Blender 2.8


Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) closed this task as Archived.Dec 8 2018, 2:18 AM
Brecht Van Lommel (brecht) claimed this task.

Cycles: OpenCL on macOS has been disabled

There was a growing payload of bugs in Cycles related on OpenCL on macOS
platform, and those issues were caused by a compiler bug, which we have no
control over.

Surely, it is sometimes possible to work compiler bugs around from a
source, but we are facing some of the issues which are not solvable in this
way. Also, such solutions are usually short-living,. since adding more
features are often kicking compiler to provide buggy binary again.

In this case compiler will not get fixed since Apple decided to discontinue
OpenCL on its platform.

So the decision was made to drop support of OpenCL, keep official features
of Blender stable and predictable, and focus on things we have control over.

P.S. Older Blender releases are always available. Surely, this sounds like
using an ancient software without neat features. But we can't push Cycles
OpenCL on macOS measurably beyond that anyway.

https://lists.blender.org/pipermail/bf-committers/2018-December/049695.html

Thats unfortunate for us Mac users... I guess there is not much of a chance that we will see Metal support in the future - maybe through the help of MoltenVK?