Page MenuHome

Scene too complex to fit in available memory, with lots of VRAM to spare
Closed, ArchivedPublic

Description

System Information
MacOS, Macbook Pro 15" 2017, i7-7700HQ / Radeon Pro 560 4GB

Blender Version
Broken: 2.79b hash f4dc9f9
Worked: (optional) Latest build on Windows, GTX 1080 Ti

Short description of error
Throws "scene too complex to fit in available memory" before starting the render, whilst only using 700M. On Windows, the per-frame memory usage is 3GB or less, which can fit into the Mac's VRAM.

Exact steps for others to reproduce the error
On MacOS with 4GB graphics card, load blend file, render frames 600 to 800 with valid file destination, using OpenCL GPU Compute engine.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Sorry, but it seems the blend file is missing?

marking as incomplete for now

Max (MessyMix) added a comment.EditedNov 2 2018, 3:00 PM


Okay, I thought I attached it the first time around but here it is. Do I have to attach the assets used as well (HDRI, textures)? Or are they embedded in the .blend?

Hi, thx for getting back.
Yes, please pack all into the .blend. You can do so by File > External Data > Pack all into .blend

See if this can replicate the problem

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Nov 4 2018, 7:33 PM

OK, blendfile provided

@Max (MessyMix)

Hi, can you try to explain in more detail what this issue is about?
If I read and understand correctly you compare a NVidia driver on Windows to an AMD MacOS driver on Apple.
Different OSes and hardware and drivers lead to other programs and memory usage.
If this is the case the difference is in the driver and hardware.

Thanks in advance.

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.Feb 12 2019, 11:06 AM

No problem, not a very major bug at all. It may be an OS-level vRAM allocation issue.
I tried to render a frame on my Mac using the GPU which has 4GB of vram, but it said "scene too complex to fit in available memory". Which is weird, because I expected it should be small enough to fit.
So I checked it by rendering it on a 11GB GTX 1080 Ti, and the scene is only takes up 3GB of vRAM, so it should have been enough to render on the Mac.

Anyways, not a very major issue, so I will see if I can close this. Especially with the new combined CPU/GPU render capability coming up soon.

Max (MessyMix) closed this task as Archived.Feb 12 2019, 4:56 PM
Max (MessyMix) lowered the priority of this task from Needs Information from User to Confirmed, Low.