Page MenuHome

Keyframe crash
Closed, ArchivedPublic

Description

System Information
Windows 10 Pro and NVIDIA GeForce GTX 1070

Blender Version
Broken: 2.80 Alpha 2 Date: 2018-11-01 00:45 Hash: ae87adc73a2 Branch: blender2.8

**Blender crashing when deleting keyframes

Exact steps for others to reproduce the error
Using the attached file, Blender frequently crashes when deleting keyframes. I've deleted 1 or 2 or 3 (up to 10-15) without it crashing, but when I deleted 20+ (roughly) it crashes.

  1. Use B to bow select keyframes.
  1. Use XD to delete.
  1. Blender crashes.

Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Nov 2 2018, 7:18 PM

Looks like the example .blend file is missing?

Marking as incomplete until we have that...

Not sure what happened. I just dragged the file in again. I hope.

Since this is a similar setup as in T57491, could we check if this is [again] related to that BezierCircle.001 ?

Where can I go to see exactly what file I uploaded? I was working with a number of variations, and I want to make sure I'm looking at the right one.

I've edited the task description, should be more visible now... (at the bottom)

Thanks, Philipp.

I opened the file, and first, deleted about 15 keyframes with no crash. Then I deleted about 30 and it crashed. Then I reopened the program and deleted the BezierCircle.001.

Again, I deleted about 15 keyframes and it didn't crash. Then I deleted about 30 and it crashed as before. Next, I reopened the file, deleted the BezierCircule.001, then also deleted Collections 3 & 4. After that, I could delete all the keyframes I wanted, in any quantity, and the program never crashed. When I have time, ,I'll continue to experiment.

Philipp Oeser (lichtwerk) closed this task as Archived.Nov 15 2018, 8:43 PM
Philipp Oeser (lichtwerk) claimed this task.

Not sure if we can make any more progress here?
Is there still an issue with latest buildbot builds?

I'll archive this for now, but please comment again if issues persist...