Page MenuHome

Some edit mode tools cause Blender to crash with Cycles enabled in the same "edit mode session"
Closed, ResolvedPublic

Description

System Information:
CPU: Ryzen 5 2600
GPU: Radeon RX 570 4GB
OS: Windows 10 Home 64bit

Blender Version:
Broken: Blender 2.80 Beta 0f5b53ba4dc

Short description of error:
Some edit mode tools ( Smooth and Randomize) cause Blender to crash if Cycles rendering is enabled in edit mode during the same session.

Exact steps for others to reproduce the error:

  1. Open Blender with any file (Start-up file works).
  2. Change the render engine to Cycles.
  3. Enter edit mode on any object in the scene.
  4. Enter Rendered viewport mode.
  5. Select one of the two tools (Smooth or Randomize) from the tool bar and use it on the object.
  6. Blender should crash.

Note: EEVEE doesn't experience this issue.
Note 2: Entering rendered mode while in edit mode then switching to Solid, LookDev, or Wireframe mode will still cause Blender to crash when you use the tool.
Note 3: Entering rendered mode in object mode, then changing to Solid, LookDev, or Wireframe mode, then entering edit mode does not experience this issue.
Note 4: Entering rendered mode in edit mode, then switching back to Solid, LookDev, or Wireframe mode, then switching to object mode, then back to edit mode, then using a tool doesn't cause a crash.

Simplified form of notes 2-4: This crash only occurs if you have entered Cycles rendered mode will in the same "edit mode session". Exiting edit mode and re-entering it after exiting Rendered mode or using Cycles rendered mode outside of edit mode will stop the tools from causing Blender to crash.

Details

Type
Bug

Event Timeline

Alaska (Alaska) renamed this task from Edit mode tools crash with Cycles enabled in the same "edit mode session" to Some edit mode tools cause Blender to crash with Cycles enabled in the same "edit mode session".Nov 3 2018, 8:33 AM
Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Can confirm the crash.

wmGizmo->custom_modal is 0 and wmGizmoType cant be resolved.
Will also check this with ASAN...

1 gizmo_tweak_modal        wm_gizmo_group.c  520  0x1976ac0 
2 wm_handler_operator_call wm_event_system.c 1974 0x194843e 
3 wm_handlers_do_intern    wm_event_system.c 2580 0x1949d40 
4 wm_handlers_do           wm_event_system.c 2619 0x1949e42 
5 wm_event_do_handlers     wm_event_system.c 2988 0x194b01e 
6 WM_main                  wm.c              412  0x19405e0 
7 main                     creator.c         525  0x193b3b1
Alaska (Alaska) updated the task description. (Show Details)

Just tested in a newer version of Blender 2.80. The Spin tool and Spin Duplicate tool are no longer affected.

T60112 is related [potential fix D4161 in that task...]

Brecht Van Lommel (brecht) closed this task as Resolved.

This appears to be fixed.