Page MenuHome

Crash when alt + LMB click in weight paint mode
Closed, ResolvedPublic

Description

System Information
Win10 RX460

Blender Version
Blender 2.80 alpha2 32dca36afb1

Short description of error
Crash when alt + LMB click in weight paint mode

Exact steps for others to reproduce the error

  1. Enter weight paint mode
  2. Click LMB with alt

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Cannot reproduce here (as of rB469005f1f6ad).
(tried with Factory Settings on a default grid -- seems to behave normally, no crash)

  • Could you share the blendfile in question?
  • drivers up to date?
  • does this also happen with factory settings and a default grid for you?
  • does this also happen when you use the gradient tool from the toolbar?

marking as incomplete until we have these tried...

When dragging, no crash occur. JUST CLICK.

Could you share the blendfile in question?
does this also happen with factory settings and a default grid for you?

This happen with factory settings.

drivers up to date?

Yes.

does this also happen when you use the gradient tool from the toolbar?

No.

I could reproduce the crash with Debian 9.5, Celeron G3930 machine. The Blender version is 2.80 alpha2 895295a9f0c. I also builded with the patch, and I could reproduce the crash.

This is a record (windows version).

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Confirmed, Medium.Nov 7 2018, 2:26 PM

Ah, get it, seems like vert_cache has either never been created or freed before...
Also Not sure why we are in OPERATOR_CANCELLED here, will have a look...

1 paint_weight_gradient_modal paint_vertex_weight_ops.c 695  0x2266d01 
2 wm_handler_operator_call    wm_event_system.c         1974 0x1c44e23 
3 wm_handlers_do_intern       wm_event_system.c         2580 0x1c46725 
4 wm_handlers_do              wm_event_system.c         2619 0x1c46827 
5 wm_event_do_handlers        wm_event_system.c         2988 0x1c47a03

D3912 might just be a bandaid, but solves crash

Philipp Oeser (lichtwerk) closed this task as Resolved.Feb 4 2019, 11:29 AM

I cannot reproduce this anymore.
(havent hunted down the relating commit, but consider this resolved....)

@Kinouti Takahiro (dskjal): Please test again and report back if issues persist... [there should not be any really...]