Page MenuHome

2.8 Armature Rig Missing Bones/Broken
Closed, ResolvedPublic

Description

Alienware 17R4 i7 Core-7820HK CPU @ 2.90 GHz
Graphics GTX 1080 8GB

2.80.30
Character and Armature created in 2.79, but opened in to 2.8 for final render.
Half the armature is gone, (Bob.Armature.Rig) or invisible, and the other half is fine (Bob.Face.Rig) but according to animation it is still present somewhere in my file, since the keyframes still produce movement on hands, arms and shoulders.

Now under my Scene the Armatures are named "Bob.Armature.Rig" and "Bob.Face.Rig", and you can open this in 2.79 to see its functional state, but if opened in 2.8 the rig breaks as described.

Since Spring had been in production for a while, i assume you may have seen this issue while transferring from 2.79 to 2.80

Details

Type
Bug

Related Objects

Event Timeline

A form of a rig that you worked on in the Glass Half production, could you see what went wrong?

Philipp Oeser (lichtwerk) triaged this task as Normal priority.

Can confirm some custom bone shapes are missing a refresh to draw correctly.

Drawing issue needs further investigation, but as a workaround you can select everything called "WGT-*" (they are all in Collection 20) and go in and out of editmode.
This brings back drawing of the custom bone shapes.

Not sure though about the "rig breaks" statement: functionality seems to be intact?

@Clément Foucault (fclem), @Sergey Sharybin (sergey): Is this something I should investigate more? Or does that ring a bell immediately?
@Clément Foucault (fclem): will assign to you first (feel free to throw back at me for further investigation...)

Brecht Van Lommel (brecht) raised the priority of this task from Normal to Confirmed, Medium.Nov 15 2018, 11:14 AM

Thank you so much, i found that trick very helpful.

I see what you mean, the rig is still fully intact it's just not active initially, but after going into edit mode and coming back out it does bring the custom bone shapes back again. Then after saving the file it is back to normal again.

I hope you are able to fix that for everyone else as well in the future updates, Thank you again

Clément Foucault (fclem) closed this task as Resolved.Mar 20 2019, 2:45 PM

Everything seems to be normal to me now. Don't hesitate to reopen if that's not the case.

I just downloaded the newest 2.80 build and tried to open blend file from 2.79c. It turned out my rigs are missing, it's greyed out.

I can jump from one point to another in the time line and I can see the transformation of the mesh caused by rig, but I can't select the rig and view in pose mode or edit mode. I assume I can't play animation thanks to that as well (clicking play does nothing). Plus, meshes with applied physics are also gone.