Page MenuHome

Rendering on gpu glitched, cpu works fine.
Closed, InvalidPublic

Description

System Information
Windows 10 latest version, amd 64 vega gpu with both recommended and experimental drivers

Broken: Blender 2.79:b97a2c3688a
Worked: None now, tried reinstalling several different versions including 2.8
So using my gpu in blender is completely a non option it seems, the best example i can give is i today tried to open a file id been working on, a small building, and several of the parts were not rendering, others rendering albeit with strange shading and stretches, ive appended none of my files or changed any structures, nor tried anything other than reinstalling blender, drivers, and trying to load older file versions, however stranger still when rendering on the cpu everything is perfect and as i left it, i wondered if maybe my gpu was now broken but all my gaming benchmarks, and indeed games, work with the same results as prior, give or take a few fps for driver differences., i will try to attach a few pictures to illustrate my issue.

Also i have completely restored factory blender settings but enabled my gpu.

To my knowledge i have not updated or changed any settings, and only did so as a result of this issue, i am indeed quite perplexed.

This is the image unrendered.

This is what it now looks like using gpu (same result with experimental box ticked)

This is what it should look like (i removed all texture slots but kept lighting)

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Seems to be something wrong with Vega 64 (and newest divers?), there are other (more specific issues reported, see e.g. T57832)

But for completeness (so that this is reproducable) we need your blendfile here.
Could you upload that to the task desciption?

Marking as incomplete until we have that...

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.