Page MenuHome

Motion tracking 'Display what the algorithm sees in the preview' not working while testing R or G or B options
Closed, ResolvedPublic

Description

System Information
OS Windows 10 64bit
CPU Ryzen 7 2700x 8 core 4.3 Ghz
GPU Nvidia 1080ti

Blender Version
Broken: 2.8

Worked: 2.79b and previous versions

Short description of error
The small window that displays the motion tracker has an option to display what the algorithm sees with the options R,G,B, In previous version when selection any of the RGB options the window would immediately show what the algorithm sees but that is no longer the case, now the window does not update unless the marker is selected once again even when said marker was already selected thus creating a problem because now every time the uses wants to see the R,G,B options the marker has to be clicked adding unnecessary clicks.

Previous versions use to be, click R the algorithm would show immediately,
2.8 the user clicks R and algorithm will not display unless the user licks the marker again.

Exact steps for others to reproduce the error
Open motion tracking.
Load video file
Create a marker
Activate 'Display what the marker sees in the preview
Click R or G or B to compare what the algorithm sees, realize that nothing happens
User has to to click the marker again every time R or G or B is selected.

Details

Type
Bug

Event Timeline

Sebastian Koenig (sebastian_k) triaged this task as Confirmed priority.Sun, Nov 18, 9:40 AM

Yes, I can confirm that.

There seems to be some kind of UI update call missing, or something like that.
And there is a probably related issue with a missing UI update:
The clip editor's graph view is not updating properly when you activate the button to only show selected tracks or when you use the Filter option (to the right in the graph view header), only if you change the current frame or click somewhere in the editor it updates.

Sergey Sharybin (sergey) closed this task as Resolved.Mon, Nov 19, 1:32 PM
Sergey Sharybin (sergey) claimed this task.

This got fixed by rB9b8d479e414.

Thanks for the report, closing it now.