Page MenuHome

Theme bug in 2.8 documentation site.
Closed, ResolvedPublic

Description

I've got a link to the new 2.8 documentation, and I've seem a weird bug of missing text.
Seems like a theme problem.

https://docs.blender.org/api/blender2.8/

Details

Type
Bug

Event Timeline

Christian Lutz (LosBopfos) claimed this task.

Nothing wrong.
Could be closed I think.

I still see the bug, either in chrome or firefox.
maybe because I am using windows 7.

@Christian Lutz (LosBopfos), please leave triaging reports like this to developers.

Does https://docs.blender.org/manual/en/latest/ have the same problem?

Also are you using any particular web protection software? VPN? Ect...

@Aaron Carlisle (Blendify)
No messages in console

here is the .har file:

and I am not using any vpn or network protection, no adblocker enabled also.

The second GET-request to https://docs.blender.org/api/blender2.8/ in your .har-file returns all the data in the html. Perhaps this is a rendering bug in your browser?

I tried with both Firefox and chrome, and the bug happens exactly the same, since I disabled hardware acceleration on chrome and it happens exactly like in Firefox which have acceleration enabled, I guess it's not a hardware specific problem neither software specific.

Just installed Opera to test and the same bug happens:

Oh, I guess I figured out.
It looks like a font rendering problem:

The source fonts Lato-Bold.wolf2 and Lato-Regular.wolf2 aren't rendering even in the preview from the browser


Roboslab and Fontawesome fonst are working fine.

That is a bit strange. If your browser wouldn't support, it should load the *.ttf as declared in the font-face definition.

Its loading all *.wolf2 fonts but somehow its not rendering some of them

Could you try to load this page and see if it renders properly (and if it loads the .woff2 files or another format)?

It should look like this:

Everything looks fine in this page:

Brecht Van Lommel (brecht) triaged this task as Low priority.Thu, Nov 22, 8:46 PM

The Blender manual and 2.8 API docs are not being built on the same machine, probably using a different sphinx version or font file version. Either Windows 7 (32bit?) or the font file has a bug.

I guess it could be worked around by using a different font.

The sphinx build shouldn't be a problem, everything down to the font-face definition in the css is correct. I think it's either a weird bug on @Jean Da Costa (jeacom256)'s system or the font file has some obscure error. The easiest way is to replace the Lato .woff2 files with a current version. That definitively won't break anything and possible fixes the problem, since the current version of Lato seems to render just fine.

Apparently there was an error with the extended latin characters in the Lato font in case your sphinx_rtd_theme still uses the pre August 2014 version.

I've just downloaded new font files and replaced on a downloaded copy of the manual and this seems to fix the problem.
Hope someone do the same the the official docs..

The api docs are being compiled with a older version probably 0.3.x the official version that we have now is 0.4.x which included fixes to the font stack. Who ever is in charge of this build system needs to make sure that they use the versions that are defined in the requirements.txt file.

@Bastien Montagne (mont29), since you are uploading these, can you try to upgrade to the latest sphinx version that fixes this problem?

Am using debian testing packages, which seems to be 0.4.2 for the shpinx-rtd-theme one.

I think issue is rather within the API doc directory itself, we store our 'own' theme there, think it's just a matter of updating font file there and rebuilding… will try quickly now, otherwise that will have to wait for Sunday.

Hmrrpf no, looks like our theme dir is minimal and does not includes fonts and such… And can confirm that fonts on API doc server and those from my debian package are exactly the same… :|

@Bastien Montagne (mont29) replacing the fonts in .\site-packages\sphinx_rtd_theme\static\fonts would then be the easiest way. Sphinx only copies those files anyway, so as long as the replacement files have the same name everything will work just fine.

@Robert Guetzkow (rjg) not sure about that, again current font files are recent ones (0.4.2 version, from this October or so)… So issue pointed out by @Aaron Carlisle (Blendify) is not the one at play here I think.

Ah, so issue is with the ttf ones in the end? This report is really confusing :/

debian's fonts-lato is indeed from before 08/2014, they probably did not repackage since then, so I guess those could be faulty. Will overwrite my system's Lato fonts and regenerate the API doc then.

Based on filenames loaded from my browser, I could check which files arent working and which ones are:

Bastien Montagne (mont29) raised the priority of this task from Low to Incomplete.Sun, Dec 2, 2:48 PM

Done, please report if this fixes your issue.

.woff2 files are latest ones. only .ttf ones were old.

Weird, it's still not working.

I believe the .woff2 files are supposed to be generated from the .ttf files, so they should have a modified date that is the same or newer than the .ttf files.

I wish I could start learning the api soon.
Can someone share a download link for the zipped docs so I can try to fix locally?

@Bastien Montagne (mont29) you must not have the latest version of sphinx_rtd_theme newer versions print the version number in the css and js files. (https://docs.blender.org/api/blender2.8/_static/css/theme.css) compare this to the master version: https://raw.githubusercontent.com/rtfd/sphinx_rtd_theme/master/sphinx_rtd_theme/static/css/theme.css

Try running: pip install sphinx_rtd_theme --upgrade

@Aaron Carlisle (Blendify) I have Debian testing version, stamped 0.4.2, which should be more than recent enough! And the problem is not there anyway, am told it’s font issue, this is not controlled by that sphinx theme. And no, I don’t want to meddle with pip if I can avoid it, distro package manager shall be the only one needed here. Since when do we need bleeding edge tools to build the docs????

and since when does this only pops up for 2.8 API doc? I’ve been building those for years with exact same package and never got any report so far… weird…

Btw, @Jean Da Costa (jeacom256) updated again also replacing woff2 lato fonts, hope this time its OK…

@Bastien Montagne (mont29) thanks for taking care of this. I would suggest using a venv for building the docs though, that makes it far easier to have the same versions as the main docs and perform upgrades as needed. No bleeding edge is certainly not required, but system packages may not be equal to the ones in available as pip package.

@Bastien Montagne (mont29) you obviously don't have 0.4.2 version of sphinx_rtd_theme the theme assets simply do not match 0.4.2. You can confirm by checking the output of pip freeze or this python script:

from sphinx_rtd_theme import __version__

print(__version__)

We don't need bleeding edge tools, however, in this case we (speaking with a Read the Docs contributor hat) recently updated the packaging of font assets and our font stack. So if we are having an issue with font rendering thats the first step to try to fix it, simply using the latest version.

Now the manual is working to me now, thankyou guys!

@Aaron Carlisle (Blendify) I do…

>>> from sphinx_rtd_theme import __version__
>>> __version__
'0.4.2'
Bastien Montagne (mont29) closed this task as Resolved.Mon, Dec 3, 4:54 PM

@Jean Da Costa (jeacom256) Thanks, closing then, will report the issue to debian too…