Page MenuHome

VSE: AV-Sync causes caching to fail
Closed, InvalidPublic

Description

System Information
Ubuntu Linux, GTX 1080

Blender Version
Broken: Blender 2.8, 2.79b

Exact steps for others to reproduce the error
How to reproduce:

  • Load a clip in the VSE
  • Set playback method to AV-Sync
  • The sequence will not be cached and will not play at the target frame rate.

Setting playback to No Sync makes caching work.

Details

Type
To Do

Event Timeline

Physics caching also doesn't work with this option. It seems like caching in general doesn't work with AV Sync.

Brecht Van Lommel (brecht) triaged this task as Confirmed, Medium priority.Nov 24 2018, 10:56 PM
Brecht Van Lommel (brecht) updated the task description. (Show Details)
Brecht Van Lommel (brecht) changed Type from Bug to To Do.
Richard Antalik (ISS) closed this task as Invalid.Feb 23 2019, 11:09 PM
Richard Antalik (ISS) claimed this task.

I can not confirm this.

With A/V sync enabled, frames are skipped and therefore there are "holes" in the cache. You would have to play section several times to be fully cached.

D3934: VSE cache with frame prefetching (WIP) will make it easier to fill the cache in advance + actually see the cache.

This is not a bug.

Only way around this, is threaded significantly faster rendering and preview drawing.
Prefetching is threaded rendering, so it's just a partial solution.