Page MenuHome

Animation keeps playing after Clear Keyframes
Closed, ResolvedPublic

Description

System Information
Linux, GTX 1080

Blender Version
Broken: 2.80 - 7b0f638ff63

Short description of error
When keyframes are cleared from an object, the animation is still played back until the file is reloaded.

Exact steps for others to reproduce the error

  1. Turn on auto keying and make some keyframes
  2. Clear keyframes and play the timeline

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Confirmed priority.Nov 23 2018, 3:41 PM

Confirmed with using "Clear Keyframes", in the RMB menu on the Location property.

@Sergey Sharybin (sergey), I guess some kind of missing depsgraph tag.

A related issue with actions (I assume), in case it helps with finding the cause:

  1. Animate default cube
  2. Clear keyframes from object properties
  3. Play timeline (cube still moves)
  4. Move cube, but don't add a keyframe (cube stops moving in the animation)
  5. In the action editor, assign the now empty action back to the cube

-> the loc value is still animated but the cube doesn't move in playback

Sergey Sharybin (sergey) closed this task as Resolved.Dec 4 2018, 4:09 PM

Pretty much sure this has been fixed as a part of T58117 (at least my interpretation of steps got fixed).

If the issue will still exist with the next round of buildbot builds, please make a new report with an updated steps and .blend file.