Page MenuHome

FBX version options & Nuke .chan add-on issues in v2.79 and v2.8
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

blender2.79 ( worked with issue )

blender-2.80-e829e47b558-win64 ( missing FBX version options & Nuke .chan add-on )

Short description of error

blender2.79

bug: FBX export in ver. FBX 6.1 ASCII
issue: one frame offset in the head frame when imported to Nuke compare to Alembic cache exported from the same scene

blender-2.80-e829e47b558-win64

bug: FBX export
issue: 1. missing version option drop down menu ( I know ver. 6.1 ASCII is old and no longer being supported, but it'd be great to have it as an option for Nuke or other purposes )

  1. the current version of FBX is having scale and orientation issues when imported to Nuke comparing to the Alembic cache

bug: Nuke .chan add-on
issue: missing in the Add-ons menu

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Stephen (SWDesign) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Nov 25 2018, 3:40 PM

Please avoid multiple issues in a single report.
(Just makes it hard to address these one at a time)

  • reg. FBX ASCII in 2.8: this has been removed on purpose (see T53877)
  • reg. FBX ASCII in 2.79 frame offset: chances are very slim that this will be addressed, all resources are focused on the current (binary) exporter
  • reg. Nuke .chan addon: this hasnt been updated to 2.8 yet and thus is not available for the time being...

Now that leaves us with:

the current version of FBX is having scale and orientation issues when imported to Nuke comparing to the Alembic cache

  • There are a couple of options regarding transforms in the exporter (see rBA8b2a241baca0 [and possibly the related tasks mentioned in that commit message]), have you tried these?
  • Is this just an issue with Nuke? (is a roundtrip blender > FBX > blender OK?)
  • In any case we would need an example .blend (and a precise description of how this fails in Nuke), could you share this here?

Marking as incomplete until we hear back...

Stephen (SWDesign) added a comment.EditedNov 26 2018, 8:41 AM

Hello Philipp,

reg. Nuke .chan addon: this hasnt been updated to 2.8 yet and thus is not available for the time being...

Thanks for confirming this will eventually be put back in 2.8 in the future version

the current version of FBX is having scale and orientation issues when imported to Nuke comparing to the Alembic cache

This is an issue for both Nuke and Blender roundtrip (blender > FBX > nuke) & (blender > FBX > blender)
forgot to mention the animation info also disappeared

The alembic cache appears to be nearly 1:1 in blender so in this case I'm using the alembic as the correct reference.

Nuke 3d viewport screen cap:

Alembic is highlighted very tiny on the ground plane in comparison to the gigantic FBX

Blender 3d viewport screen cap:

Alembic is highlighted and matching 1:1 to Original Suzane
FBX is mis-positioned and animation info are lost

geoExportTest file ( including both Nuke and Blender scene) is attached below

Thanks,
SW

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Jan 9 2019, 7:34 PM

Information is given, needs another look...

Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

I can confirm that with blender -> fbx -> blender , the animation is lost and the object is miss positioned.

Bastien Montagne (mont29) closed this task as Archived.Feb 11 2019, 1:57 PM

Animation info is not 'lost', it's just 'disconnected' (due to how FBX anim system works (and is cryptic), it's not really possible to keep/convey the concept of Action through it). You simply have to re-assign the right action to the right object after re-importing into blender. Disabling All Actions and NLA options in FBX export settings would also help here, I guess (should generate much less animation data).

As for relation between empty and monkey, you are using a constraint, this is not supported by the exporter currently, only plain basic parenting is (…to some extend, it's not always working perfectly well :| ).

But by all means, if Alembic is working for your pipeline, please, please use Alembic! You'll be using an open, well documented and future-proof format, while FBX is a broken-by-design, totally opaque closed-sourced format… And in general, it's much better/safer to use fully baked formats (like Alembic) for exchanges, complex setups involving animation, armatures, constraints etc. are seldom properly converted between different apps.