Page MenuHome

Crash when adding particles to an already animated Soft Body
Closed, ResolvedPublic

Description

System Information
Windows 10, GTX1070

Blender Version
Broken: Blender 2.8 Alpha 2, e60c49ecf06

Short description of error
When you play the animation on a soft body and then try to add particles, Blender crashes

Exact steps for others to reproduce the error

  1. Create a new blender scene
  2. Select the default cube
  3. Open the Physics panel
  4. Select Soft Body
  5. Play the animation for a few frames
  6. Open the Particles panel
  7. Press Add

Blender will crash

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Nov 27 2018, 1:39 PM

This seems to be fixed already? (cannot reproduce)
@Mal Duffin (mal_cando): does this still happen for you with latest 2.8?

Hi @Philipp Oeser (lichtwerk), this is still happening here for me ( in the build from the latest source - 32ab0647a53 ).

Just to be totally sure: can you share the .blend (right before 7.)?
This has to be done while playing? (or just play a little, stop, add particle system?)
Anyways, both methods work fine here...

Hi Phillip,

I've attached the blend.

If I load that, I...

  • press Shift and SPACE to run the anim for a few seconds.
  • then hit Escape to cancel.

When I add a particle system to it, it crashes here.

Weirdly, I can add the particle system while the animation is playing!

Hm, still nothing...

(these are just shots in the dark:)

  • does this happen with Factory Settings as well?
  • does this happen with the --threads 1 commandline option?

does this happen with Factory Settings as well?

Yes, it still crashes

does this happen with the --threads 1 commandline option?

No crash when using --threads 1, or 2. It does crash with 3

Hi Phillip, I re-pulled the latest sources and did a "make clean" ( and also a clean build from Visual Studio ), and the issue now seems to be resolved!

Mal Duffin (mal_cando) closed this task as Resolved.Nov 28 2018, 2:59 PM
Mal Duffin (mal_cando) claimed this task.