Page MenuHome

Does not stand out vertex in wireframe mode
Closed, ArchivedPublic

Description

Windows 10, GTX 1050

blender-2.80.0-git.7e9389b83d8-windows64

Sometimes in the wireframe mode some vertices are not selected. In solid mode everything is in order.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

Please attach a .blend file to reproduce the problem.

This does not always happen.In previous builds it was the same. In Blender 2.7 there was no such problem.

This looks like it is doing loop select [which is mapped to doubleclick now], the active vert seems to change in you gif, too.
What I am unsure about is how another click has the result of making the 'other' vert active again [which I cannot reproduce here]

Are you holding SHIFT down as well?

Well no.
I can not select vertex in wireframe mode. In solid mode everything is fine.
Ie I click on vertex and he does not stand out in any way. I switch to solid mode and he stands out.
This most often happens when you need to work in one projection. For example, modeling by reference. Or you need to pick a back vertex.
I was told that such a problem in Blender 2.5 was when it first appeared.
There is no such problem in Blender 2.7.

Well in you gif, it looks like the vertex is actually selected (the transform gizmo is just not the exact vertex position because other verts have also been selected by loop-select [doubleclick], so the gizmo is at the median point).
That being said, this is only by looking at your gif, I cannot reproduce this with your file (even in orthographic view)

  • So you are not holding down SHIFT by any chance?
  • Does this also happen when you click slowly [so you dont trigger loop-select by doubleclick]?

Shift did not press exactly.
You want to say that the vertex is selected, but the selection itself is not displayed? I was approaching this vertex and she was still not active. I can record a video when the problem reappears.

In the settings of OpenGL there is a "Selection Method " and it is selected by default "Automatic". It cannot be that in one of them error? OpenGL Depth Picking disabled by default.

I posted a video: https://youtu.be/HTxOzgo2VS4
I hope it will be informatical

This problem may have been fixed yesterday by @Brecht Van Lommel (brecht). There was a conflict between click and press events for selection. Try again with a newer build.

I specifically downloaded the new build (blender-2.80-26b1aa99436-win64) The error is still there.
This error is most often encountered in the work of strictly one of the projections. If you rotate the camera a little, then vertex will stand out.

Could not reproduce this bug here. Works fine.

It could be a keymap issue - have you tried to go to File > Load Factory Settings and retry?

Of course, I always delete these settings.
The problem is that this error is not for everyone. Those. the probability of its occurrence is 50/50. I will add that the problem disappears when you exit editing mode.

In the comments under this video(https://youtu.be/kp2rIepnueU), Shane Martins writes: "Logical selectors is a nice feature, but is anyone else having issues with 2.8 and selecting specific vertices? It seems to consistently be grabbing the wrong one (even when I'm hyper aware of mouse cursor placement) or I've got to be looking at the vertex from a very specific angle in order to select it."

Here it seems to work fine. Can you post a blend where the problem occurs immediately? The blend file you posted seems to be different from the video. Make one where selecting a specific vertex fails and repost.

Here is{F5737172}
I'll throw off another file when this error appears again.

Here is this file. I did not touch anything. Just saved.


The same vertex do not stand out.

Unfortunately selecting this vertex works here for me every time. It could be a driver issue.

This error occurs during operation. If I reload the file or exit edit mode, the error will disappear.
I do not think. After all, at 2.7 it works fine. I'll try.
Current driver: 416.34

In general, I tried to write this bug with a new file and I got a new one. Missing vertex mapping. Video: https://youtu.be/poHGwf5G3fA (3:05)

How to reproduce this bug (https://youtu.be/4pH-g8yk_7M):

  1. While in the Vertex select mode, perform an operation. For example, extrusion.
  2. Switch to "Edge select" mode or "Face select" mode
  3. Press twice Ctrl + Z

Please only report a single issue per report.

@Characterhero (TheCharacterhero): I can confirm the issue regarding undo and select mode, but could you please open a separate report for this?

regarding the original report: it seems noone can reproduce unfortunately... not my hope in this regard...

Philipp Oeser (lichtwerk) closed this task as Archived.Mar 19 2019, 9:41 AM
Philipp Oeser (lichtwerk) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.