Page MenuHome

Crash when in EEVEE Render middle mouse with AMD RX 560 GPU
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
WIN 10 latest update
Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)
Blender 2.8 HASH b4e037fe140
Short description of error
Rendered view crashes with AMD GPU
Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

When navigating the render EEVEE view in 3d view port using middle mouse button Blender crashes.

Details

Type
Bug

Event Timeline

I've tested this with an RX 570 4GB on Blender 2.8 9abcf56fa88 (November 26th) and I'm unable to recreate the crash. Try updating blender and your graphics drivers and see if the issues persist.

AMD Drivers: https://www.amd.com/en/support

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Also cannot reproduce, marking as incomplete until we have tried the newest drivers.
@Herb Brown (MusicAMG): please report back if newest drivers make a difference

I updated the drivers and it still crashes.. However, it seems to be at random. When it does crash, I get a white screen, which indicates to me the GPU went out of memory. same test blend file..

@Herb Brown (MusicAMG) : sorry this report has been lying around, is this still an issue with the newest build?

regarding the white screen: could you attach the output of running blender with the --debug-gpu [please put this in a .txt file]

Appears to be corrected. The last I saw, code was added testing the GPU for this particular card. Added was "work around" code and it fixed the problem. Additionally, the drivers were updated for the GPU as well. The latest daily builds since that have worked fine. I think it is safe to close this.

Philipp Oeser (lichtwerk) closed this task as Resolved.Jan 9 2019, 8:34 PM
Philipp Oeser (lichtwerk) claimed this task.

Glad to hear