Page MenuHome

Rendering viewport in sub-window doesn't update lights
Closed, ResolvedPublic

Description

System Information
Linux, 1080 GT

Blender Version
Broken: 2.80 bb52ef4ee9b

Short description of error
Light intensity/colour changes are only reflected in rendering viewports as long as they're in the main window.
Detaching a viewport makes it ignore this kind of changes to any light, including the World.
Changing light type or transformation seems to be no problem.

Exact steps for others to reproduce the error

  1. Detach a viewport to a sub-window.
  2. Change the intensity, colour, or texture of any light, including the World.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Incomplete priority.Nov 26 2018, 5:04 PM

I can't reproduce this in a simple .blend. If you can, can you attach it.

It may have been related to that view layer syncing thing though, which was fixed here:
rB9238b7308a3f: Fix view layer set in the outliner of child window not syncing to parent window.

Sam Van Hulle (sam_vh) closed this task as Resolved.Dec 4 2018, 11:32 AM
Sam Van Hulle (sam_vh) claimed this task.

@Brecht Van Lommel (brecht) that might be the case, I can't reproduce it myself anymore either. Thanks!