Page MenuHome

Grease pencil "stroke placement" -> stroke does nothing and works as origin (or so it seems) on MAC
Closed, InvalidPublic

Description

System Information
Mac OS High Sierra Macbook Pro 2017 15"

Blender Version
Broken: 2.8 Alpha 2
Worked: 2.8 Alpha 2 on WIndows

Short description of error
Grease pencil when set to Stroke snapping does not recognise intentions correctly on any settings and works at what seems like an origin mode. This is specific to 3D drawing. Important note that I tested this workflow on a windows machine and had no issues with snapping strokes to each other from weird angles and from orthographic.

Exact steps for others to reproduce the error
I think it's just broken on mac, I started several projects and it never works. Again on windows works just fine.

PIC
https://ibb.co/bgCpfJf

Event Timeline

I cannot help here... I cannot test in Mac, only Windows.

If someone has a Mac, I can help him to debug/test but I cannot do it myself.

Bob (voxavs) added a comment.EditedNov 26 2018, 6:34 PM


I attach my blend file it's pretty small a few kb.

I think It might have been a "user" issue after all. After testing it some more it started to work after I did the following:

  1. Select the Grease Pencil object in the selector.
  2. moved it into a new scene.

I'm not sure why it is like that but Blender seems to ignore all of the drawing if you dont specifically choose grease pencil object in the selector even though you can still draw. It might be that I'm completely wrong but that seems to me that that's why the issue happened.

Also the issue still exists in the following scenario: if you use mirror modifier apparently mirrored vertices are not real thus they can't be snapped to, which is a huge bummer, this causes making straight lines from one (original) end to another (mirrored) quite a pain. There's another thing that during the process of drawing you might end up with "real" vertices on opposite sides of the object which makes them impossible to connect to the rest of the body.

Sorry about the confusion, I spent 2 days trying to figure it out and assumed it's a bug, especially given that there's zero information I could find regarding this issue I had. Still I believe improvements can be made.

Bastien Montagne (mont29) lowered the priority of this task from 90 to Normal.Nov 29 2018, 11:20 AM

About mirror modifier I understand your request, but in grease pencil it's not easy to get what you want. You are thinking in a mirror "like" meshes, but grease pencil is not designed to work in this way. Anyway, I take a note and if possible I will add this feature in the future.

I cannot do anything on Mac.

Sybren A. Stüvel (sybren) closed this task as Invalid.EditedFeb 11 2020, 11:18 AM
Sybren A. Stüvel (sybren) claimed this task.

About mirror modifier I understand your request, but in grease pencil it's not easy to get what you want. You are thinking in a mirror "like" meshes, but grease pencil is not designed to work in this way. Anyway, I take a note and if possible I will add this feature in the future.

Based on this remark I'll close this as "not a bug".

If there are still Grease Pencil issues on macOS, please re-test with a recent daily build of Blender (https://builder.blender.org/) and file a new report. Also please only describe a single issue in a single report. That makes discussions about issues much clearer.

@Sybren A. Stüvel (sybren) The macOS problems will totally fixed with the refactor in 2.83. The problem was related to geometry shaders and these have been totally removed in the new implementation.