Page MenuHome

Crash switching to Modeling then Sculpting Workspace
Closed, ResolvedPublic

Description

System Information
Windows 10 Nvidia 1060

Blender Version
2.80 current commit.

Short description of error
Blender crashes when switching to Modeling then Sculpting Workspace.

Exact steps for others to reproduce the error

Open Blender, dismiss splash, click /Modeling\ workspace tab, click /Sculpting\ tab, crash:

Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF6DA6C2B5D
Module : G:\bdev\build_windows_Release_x64_vc15_Release\bin\release\blender.exe

Details

Type
Bug

Event Timeline

Have you guys thought about a getting into test driven development?

This crash seems to have been fixed by one of this evening's commits, but I'm not sure which one.

Can you guys confirm that it's not doing it for you either after building the latest (or get tonight's buildbot build)?

It's still crashing. If it doesn't crash at first try switching to a few tabs and then sculpt

It has always been at least a little non-deterministic like it's an uninitialized (and thus random) variable kind of thing.

Since commits from last night and still this morning I just can't get it to crash anymore here, but that may just be that the changes perturbed things just enough in my build environment that it's unable to happen or at least much less frequent.

The "if it doesn't crash at first then switch around tabs until it does" was the behavior here before as well.

Also confirmed on the latest build for Mac. UV Editing -> Sculpting also crashes.

I think this is supposed to be fixed on 1d4ad6819857 while the latest build is only 26b1aa99436 so it might indeed be fixed already but have to wait for next autobuild to confirm

Just did a fresh build, and the issue does seem to be fixed now.

Philipp Oeser (lichtwerk) closed this task as Resolved.Nov 28 2018, 2:08 PM
Philipp Oeser (lichtwerk) claimed this task.

@Benjamin Humpherys (brhumphe) : thanx for reporting back, closing as Resolved then.

everyone else: feel free to reopen if issues persit with fresh builds