Page MenuHome

Error loading file ( rigid body / soft body / hair dynamics )
Closed, ResolvedPublic

Description

System Information
Windows 10, GTX 1070

Blender Version
Broken: Blender 2.80 Alpha 2 edbf15d3c04

Short description of error
Loading of the file crashes Blender.

It's a simple example scene, created like so...

  • Create 2 cubes
  • Make one rigid body
  • Make one soft body. with no goals
  • Attach particles to each one, including hair dynamics.
  • Save the file
  • Try to re-load it - crash

Exact steps for others to reproduce the error
Load the .blend file, the crash should occur straight away

Details

Type
Bug

Event Timeline

Confirmed on build a740cc53ea1 on macOS. Running from console produces the following error:

Read blend: /Users/admin/Downloads/rigid_soft_hair_2.blend
Dependency cycle detected:
  'OBCube.GEOMETRY_UBEREVAL()' depends on 'OBCube.TRANSFORM_FINAL()' through 'Partcile Eval'
  'OBCube.TRANSFORM_FINAL()' depends on 'OBCube.TRANSFORM_OBJECT_UBEREVAL()' through 'Temp Ubereval'
  'OBCube.TRANSFORM_OBJECT_UBEREVAL()' depends on 'OBCube.RIGIDBODY_TRANSFORM_COPY()' through 'RBO Sync -> Uber (Temp)'
  'OBCube.RIGIDBODY_TRANSFORM_COPY()' depends on 'SCScene.RIGIDBODY_SIM()' through 'Rigidbody Sim Eval -> RBO Sync'
  'SCScene.RIGIDBODY_SIM()' depends on 'SCScene.RIGIDBODY_REBUILD()' through 'Rigidbody [Init -> SimStep]'
  'SCScene.RIGIDBODY_REBUILD()' depends on 'OBCube.GEOMETRY_UBEREVAL()' through 'Object Geom Eval -> Rigidbody Rebuild'
Detected 1 dependency cycles
blender(11772,0x700006b2c000) malloc: *** error for object 0x7f8f32ee7d60: pointer being freed was not allocated
blender(11772,0x700006b2c000) malloc: *** set a breakpoint in malloc_error_break to debug
Sebastian Parborg (zeddb) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Feb 4 2019, 1:42 PM

Is this still an issue with the latest beta?

As of macOS 10.14 build 38984b10ff7b it seems to open just fine, so it appears to be resolved.

Mal Duffin (mal_cando) closed this task as Resolved.Feb 4 2019, 5:09 PM
Mal Duffin (mal_cando) claimed this task.

I just tried it, the loading seems to be fixed.