Page MenuHome

Cycles GPU rendering not working properly GTX Titan (?misses light path bounces)
Closed, ResolvedPublic

Description

System Information
OS: Ubuntu 18.04.1 LTS
GPU: GTX Titan 6GB
Graphics driver: 415.18
Cuda version: 10.0

Blender Version
Broken: Blender 2.8 8850875866a
Worked: Blender 2.79b

Short description of error

The rendering doesn't work properly on my GTX Titan with Cycles. Somehow hit looks like bounces are terminated or something or the light information in the rays is not stored properly. As a result the reflections and refractions turn out black, easily visible in the glass cube but also the green of the cube is not reflected on the plane underneath.

I have no problems with Blender 2.79b there Cycles renders properly.

Exact steps for others to reproduce the error

  • Set Cycles Compute Device in User preferences to CUDA capable device GTX Titan
  • Select GPU in rendering settings
  • Render image



Details

Type
Bug

Event Timeline

Casper van Leeuwen (casperl) renamed this task from Cycles GPU rendering not working properly (?misses light path bounces) to Cycles GPU rendering not working properly GTX Titan (?misses light path bounces).
Casper van Leeuwen (casperl) triaged this task as High priority.Thu, Nov 29, 2:39 PM
LazyDodo (LazyDodo) raised the priority of this task from High to Needs Triage.Thu, Nov 29, 2:54 PM

please do not assign priority your self.

LazyDodo (LazyDodo) closed this task as Archived.Thu, Nov 29, 2:56 PM
LazyDodo (LazyDodo) claimed this task.

also that's a cuda 10 bug, use 9.1 and you'll be allright.

With you closing this bug, I might assume that is already in the progress of fixing? Will CUDA 10 ever be supported?

Sorry for the priority setting, didn't know that was not allowed.

It's a bug in cuda10(some cards)/9.2(all cards) we cannot work around, nvidia has been informed, there's nothing we can do on our side, so no need to keep a ticket open.

Just had another look I have now version 9.1, its still not working and it was a prebuild version of Blender downloaded from the blender.org website, doesn't that come with CUDA itself?

Still it is not working on my system.

LazyDodo (LazyDodo) reopened this task as Open.Thu, Nov 29, 3:29 PM

if 9.1 doesn't work, it's definitely a different bug, opening back up.

@LazyDodo (LazyDodo) So just to get some clearity, the known CUDA bug you mentioned only applies to 2.80 (while 2.79 used different CUDA code and isn't affected)? And it's now up to NVIDIA to fix this? How does that go together with Blender's apparent policy of trying to keep the used CUDA version low, so older GPUs can still be used? NVIDIA won't release any fix in CUDA 9.x anymore, I suspect.

And using CUDA 9.1 isn't a very attractive solution, as most Linux distros these days come with 9.2 or even 10, as 9.1 is already a year old.

Apologies, I was looking at the wrong CUDA version I think. My driver version was still 10.0 and my runtime version was 9.1. But here is the problem I have.. The driver versions are coupled with the graphics driver somehow, I can't figure out how to install the CUDA driver version to a year older version without downgrading my graphics driver to a year old version...

I irks me that my 2.79 version works perfectly with CUDA 10 installed but 2.8 not, that 2.8 with CUDA 10 works perfectly on my laptop but not on my workstation and that I have to install a year old graphics driver in order to use the newest version of Blender, that doesn't make sense.

Do you have any information, thread or bug report which I can follow which shows the CUDA problems with blender? I am very curious on the why's and how's of this whole issue, because something like this needs to be working properly.

@LazyDodo (LazyDodo) it seems to be fixed in the blender 2.8 beta!! @Paul Melis (paulmelis) can you confirm that it also works for you?

there's some background on the cuda 9.1/10 issue in T56858 but as i said earlier if 9.1 doesn't work for this issue, it's very likely a different issue and we shouldn't be mixing the reports cause that'll just confuse everyone.

Brecht Van Lommel (brecht) closed this task as Resolved.Fri, Dec 7, 6:25 PM

The Linux buildbot was using CUDA 9.2 for a while apparently, this is fixed now.