Page MenuHome

Subdivision modifier crash with edit mode view + Auto smoothing
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GTX 1070

Blender Version
Broken:
2.80, 26d5a3625ed, blender2.8, 2018-11-29
Worked: (optional)
Short description of error
Subdivision modifier with 'adjust edit cage to modifier result' turned on will crash blender.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
Add subD modifier with 'adjust edit cage to modifier result' + 'display modifier in edit mode' turned on.

subdivide mesh 4 times using right click mesh menu.

Turn on autosmoothing

Details

Type
Bug

Event Timeline

Vaughan Ling (heavypoly) renamed this task from Subdivision modifier crash with edit mode view to Subdivision modifier crash with edit mode view + Auto smoothing.
Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Cannot reproduce here.

Maybe a misunderstanding, I can happily subdivide following file a couple of times without crash

  • Do you get a crash in this file, too?
  • Have you tried the latest buildbot build?

Marking as incomplete until we have these answered...

Seems to be working fine in the past week's builds! Thank you. It was broken for about a week around the time of this bug report.

Philipp Oeser (lichtwerk) closed this task as Resolved.Jan 9 2019, 7:49 PM
Philipp Oeser (lichtwerk) claimed this task.

Seems to be working fine in the past week's builds! Thank you. It was broken for about a week around the time of this bug report.

Glad to hear, closing then...