Page MenuHome

Crash when adjusting a torous in edit mode
Closed, ResolvedPublic

Description

System Information
Operating system: windows 10
Graphics card: NVIDIA GX940

Blender Version
Broken:No
2.80 Beta release)
2.80 26d5a3625ed

Short description of error

Blender crashes immediately when you try to adjust a tourous object in edit mode , add the object, go into edit mode clcik on the preoperties window on the lower left corner adjust any seeting in there and it will crash blender imideately.

Details

Type
Bug

Event Timeline

Can't redo this error in editmode or object mode. 6dbc820633eb06d66bb9cbf6880ec7b37c622cd9

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Cannot redo either.

Also, you description is a bit weird, as I understand it, you:

  1. Add torus object while in Object mode
  2. Switch to Edit mode
  3. Use the 'adjust' panel of the 'add torus' operator to edit its settings.

Well… #3 should for sure not be possible, since switching to Edit mode is also calling an operator, which means you cannot adjust 'add torus' one after that.

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Confirmed, Medium.

Pretty hard to reproduce, but I could get it to crash:

  • enter editmode on default cube
  • add torus in editmode
  • go wild on adjusting segments and/or radius

BLI_assert((id->tag & LIB_TAG_COPIED_ON_WRITE) != 0);
I'm confused because debugger says id->tag is 233472 / 111001000000000000 here [which should be OK?]
Also ran a session with --threads 1 and wiggeling on the sliders survived this... [hint to race condition?]

1  raise						0x7ffff466853f 
2  abort						0x7ffff4652895 
3  DEG_get_original_id 					depsgraph_query.cc 246  0x2f1ad39      
4  DEG_get_original_object				depsgraph_query.cc 235  0x2f1aca5      
5  object_get_datamask					DerivedMesh.c      2073 0x29a545f      
6  makeDerivedMesh					DerivedMesh.c      2114 0x29a558b      
7  BKE_object_handle_data_update			object_update.c    205  0x2b3621f      
8  BKE_object_eval_uber_data 				object_update.c    348  0x2b36922

Like I said, hard to reproduce, but maybe @Sergey Sharybin (sergey) can start wiggeling, too?

@Philipp Oeser (lichtwerk), can not redo the issue here, but i am on Linux. Is that an issue? Or maybe something else got fixed? Mind checking latest 2.8 branch, and if it's still crashing mind getting a full backtraces? Also check on which is that id (is that object or mesh?)

@Sergey Sharybin (sergey): on linux, too, but cannot get it to crash anymore either (so might be fixed already)
@Jay Edwards (JayE01) : can you confirm this is fixed for as well?

Bastien Montagne (mont29) lowered the priority of this task from Confirmed, Medium to Needs Information from User.Dec 4 2018, 3:52 PM
Philipp Oeser (lichtwerk) closed this task as Resolved.Jan 9 2019, 7:57 PM

Since we didnt hear back, I'll asumme this has been fixed...
(feel free though to comment again if issues persist...)