Page MenuHome

Render time going crazy!
Closed, ArchivedPublic

Description

Operating system: Windows 10
Graphics card: Nvidia Geforce GTX 960
CPU: i7 860

Broken: 3ed0d5b4d4c

so I've been rendering with cycles in the newest 2.8 build, and been enjoying it a lot. BUT I set my pc to render overnight and set the samples to be done rendering about 13 hours later (as it said in the REMAINING text at the top bare when rendering) then when I checked the morning after it was at like "150 hours left." I then took some time to figure out what was happening. So i stopped the render, and just started the render over again to check. after about 5 minutes it started going 2 minutes up each second

I started the render in cycles, and experimented with tile size, and set it to 32 (rendering with CPU) and the samples to about 5000. I hit render, and the time goes up 1-2 minutes per seconds. Then tried with other projects, and the same thing happened. Then blender is crashing when rendering with GPU...

The weird part is that I am able to render the whole thing in 2.7(what i also ended up with) both with cpu and gpu

Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Needs Information from User priority.

Thanks for the report, but we need a .blend and steps to redo the issue.

The render time estimation is not exact, it is based on the tiles rendered so far. But if later tiles are slower to render, the estimated time is adjusted. If it's failing in some case we need a way to redo it.

Thanks for the report, but we need a .blend and steps to redo the issue.
The render time estimation is not exact, it is based on the tiles rendered so far. But if later tiles are slower to render, the estimated time is adjusted. If it's failing in some case we need a way to redo it.

ooops...blend file coming in a sec

@Mattis Kristensen (mattismoel)
I don't know if this will make much of a difference, but are you able to include textures in your blend file so we have identical test setups?

  1. Open the original blend file.
  2. In the top bar select File>External Data>Pack All Into .blend
  3. Save the file somewhere and re upload it to this site

At the moment I'm unable to reproduce the issue reported, however I'm only 6 minutes into the render:
System Specs:
CPU: Ryzen 5 2600 (Used for rendering)
GPU: RX 570 4GB
OS: Windows 10 Home 64bit
Blender Version: Blender 2.8 beta 26d5a3625ed

Alaska (Alaska) added a comment.EditedNov 30 2018, 8:03 AM

I'm roughly 8 hours into the render of the scene with the missing textures. I'm 48% complete and the estimation lists another ~8 hours until completion (The original prediction was ~2 hours. This has extended due to the fact that the original estimation based on the rendering of the sky, but not to the 150 hours you were reporting). I'm using the same system as before:
CPU: Ryzen 5 2600 (Used for this render)
GPU: RX 570 4GB
OS: Windows 10 Home 64bit
Blender Version: Blender 2.8 beta 26d5a3625ed

I'll let this finish over night. If I face any issues I'll leave a response. If nothing occurs, then I'll conclude that the issue may be on your end.

On that topic, are you able to list what CPU you're using? You said you were using it in the render tests that experienced issues. This may be related to the recent adjustments to Threadripper scheduling and may be why I don't experience the issue on my Ryzen. It's also possible the issue is with your textures, the version of Blender used and enhancements in recent commits, or possibly something else like malware taking up system resources while Blender is in use. I'd recommend you check the malware option. To do so, follow the steps below:

  1. Render the scene, once the time starts to extend at the "2 minutes per second" rate continue to the next steps.
  2. Open task manager (Right click task bar and select "Task Manager") and click on "More details".
  3. In task manager check the tab listed as "CPU". If it's greater than 80%, then your CPU is efficiently utilized. If it's lower then you're probably facing an issue else where.
  4. In the case where the CPU utilization is greater than 80%, select the CPU tab and check which programs are using the CPU. The highest one should be Blender. If Blender isn't at the top, then close that program (unless it contains important information).
  5. Report here with your results.

@Brecht Van Lommel (brecht)
I've rendered the scene (it was missing textures so the test wasn't identical) and the total time of render was roughly 15 hours on my Ryzen 5 2600. I believe the issue may be on the users end (E.G. Other programs using the CPU, overheating and thermal throttling on the CPU, etc) but more testing would need to be done to ensure this isn't the case. I'll leave this task with you.

Brecht Van Lommel (brecht) closed this task as Archived.Dec 5 2018, 4:31 PM
Brecht Van Lommel (brecht) claimed this task.

As far as I know GPU render crashes should be fixed since this was reported.

Regarding the time estimation, it's not very smart but there is not that much we can do. In this file it starts in the center of the render where there is nothing, so based on those first tiles the estimate is for it to render much faster, then as it encounters slower tiles it adjusts the estimation.

We could try to improve this once, though it's not obviously a good idea to change the tile order just to get a better time estimation.